Menu Content

Podpora

> Diskusní fóra, FAQs & placená podpora
Welcome, Guest
Username Password: Remember me

Language code in URL for main language
(1 viewing) (1) Guest
Support forum for customers who have purchased JoomSEF 4 (Joomla 1.6/1.7/2.5+ compatible). Archive only, no new post can be added.

NOTE: This category has been locked. If you have purchased paid version, please, use our Support Ticket system instead. If you are using free edition, please see the Community Support section.
  • Page:
  • 1

TOPIC: Language code in URL for main language

Language code in URL for main language 10 years, 4 months ago #42957

I'm testing Joomsef on a Joomla 3.2.2 multilanguage site. I'm trying to configure the component in order to get the language code in URL for the secondary language only, but it still appears the main language too.
On Joomsef 4.4.2 changelog I read: "Improved: No language code in URL for main language".
My version is 4.5.1.
What am I doing wrong?
Thanks.
Roberto
The topic has been locked.

Re: Language code in URL for main language 10 years, 4 months ago #43024

  • pama
  • OFFLINE
  • Posts: 489
Hello. JoomSEF is able to do that. Relevant settings are in Language tab:
Always use language (no)
Always use language for homepage (no)
Main language (also set is same as default language in Joomla lang. manager)
After that re-generate all URLs, because they have the prefix stored.
I cannot tell you exact combination of settings how to achieve that, but it is possible.
ARTIO Support Team
The topic has been locked.

Re: Language code in URL for main language 10 years, 4 months ago #43108

rbetti wrote:
I'm testing Joomsef on a Joomla 3.2.2 multilanguage site. I'm trying to configure the component in order to get the language code in URL for the secondary language only, but it still appears the main language too.
On Joomsef 4.4.2 changelog I read: "Improved: No language code in URL for main language".
My version is 4.5.1.
What am I doing wrong?
Thanks.
Roberto


Hi,

I have the similar problem,
please see www.artio.net/support-forums/joomsef/cus...nguage-article#43105
is your secondary language url work fine? if yes, Which component generated content/ k2 or other?

Thanks for your help,
The topic has been locked.

Re: Language code in URL for main language 10 years, 4 months ago #43109

Hi,
yes, I solved the problem using the settings suggested by Pama in the previuos message.
The content is generated by a custom component.

Roberto
The topic has been locked.

Re: Language code in URL for main language 10 years, 4 months ago #43113

rbetti wrote:
Hi,
yes, I solved the problem using the settings suggested by Pama in the previuos message.
The content is generated by a custom component.

Roberto


Hi,

I have the same settings, but still failed.
Can you tell me about your custom component name/ if it is convenient for you.

Thanks,
The topic has been locked.
  • Page:
  • 1
Přihlášení uživatele Prázdný