Menu Content

Podpora

> Diskusní fóra, FAQs & placená podpora
Welcome, Guest
Username Password: Remember me

[SOLVED]This component is not working properly...
(1 viewing) (1) Guest
PDF Invoice generator and editor for Joomla and VirtueMart.

If your topic falls within one of the subcategories, then please post it directly there. Post to this parent category only if your question does not match any subcategory topic.
  • Page:
  • 1
  • 2

TOPIC: [SOLVED]This component is not working properly...

[SOLVED]This component is not working properly... 10 years, 6 months ago #20963

  • pprle
  • OFFLINE
  • Posts: 19
This component does not work properly...

VM_invoice + EU VAT check installed.

1. ALL orders are transferred in the invoice list even refunded and cancelled orders. This makes the invoice order numbers incorrect...

2. Foreign companies with VAT registration are invoiced WITH vat!! They should not!

3. Shopper does receive the mails but not the shopkeeper.

Sooo disappointed.
Can you please explain how to fix this.
Thank you.
Last Edit: 10 years, 6 months ago by pprle. Reason: Solved
The topic has been locked.

Re: This component is not working properly... 10 years, 6 months ago #20986

  • jaku
Hello,

ad 1) you can set on what order status, the invoice is generated;
if you talk about case when the invoice was once generated (on confirmed status) and later cancelled or refunded, than it is correct, that it keeps its number

ad 2) this may be related to VirtueMart settings; VM Invoice only takes information coming from VirtueMart; so make sure you have the tax mode in VirtueMart set to EU mode

ad 3) the only reason here I can see that either your VM Invoice is not configured to send emails to both or the shopkeepers email address is not valid or there is some mailing prolem; again, the only role here of VM Invoice is to load the shopkeepers email from VirtueMart settings, compose the email and sent it thorugh Joomla;
if the email to shopper is sent normally, then I think the problem cannot be in VM Invoice (as it send both the email at once, so obviously, they are sent, just the one does not seem to be delivered)
The topic has been locked.

Re: This component is not working properly... 10 years, 6 months ago #20993

  • pprle
  • OFFLINE
  • Posts: 19
Hello Jan,

1. ALL and ANY (regardless the status, also the Pending ones) orders are transferred in the invoice list and is incrementing order N° leading to wrong numbering.

2. The invoice manager is acting in a very very weird way...Just after buying the module it generated invoices without VAT but with VAT on Shipping costs??
I now have two pending orders 1 GB VAT and 1 DE VAT; both previews are generated with vat!
Virtuemart orders are also WITH vat... Virtuemart tax mode is set to EU mode. The module already generated invoices without vat, so it should be configured the right way...
Might this problem come from your EU_VAT Check then??

3. This is a common problem in this forum (opened one myself) that is really not solved yet. We can select any configuration it never does what you ask... Though I can live without it since the beginning, it is not working properly.

Cheers
The topic has been locked.

Re: This component is not working properly... 10 years, 6 months ago #20995

Hello Jan!

to 3) I have the same problem!!! Since your Update 1.4.2 to 1.4.3 the shopkeeper didn't get an eMail!
First i was in contact with michal unzeitig, a member of artio, but he didn't had a solution for the problem.
So it's not a problem with the configuration! It's a problem with VM Invoice!
The topic has been locked.

Re: This component is not working properly... 10 years, 6 months ago #21020

  • jaku
Hello,

we have checked the configuration and there was really a typo. Now we have fixed this in 1.4.9.
The topic has been locked.

Re: This component is not working properly... 10 years, 6 months ago #21024

It works!!!!! Jipiiiiiiii!!!!
The topic has been locked.
  • Page:
  • 1
  • 2
Přihlášení uživatele Prázdný