Menu Content

Podpora

> Diskusní fóra, FAQs & placená podpora
Welcome, Guest
Username Password: Remember me

EU VAT ID check installation problem
(1 viewing) (1) Guest

TOPIC: EU VAT ID check installation problem

Re: EU VAT ID check installation problem 13 years, 4 months ago #19756

  • jaku
Hello, just the installer script was changed. The rest should be ok.
The topic has been locked.

Re: EU VAT ID check installation problem 13 years, 3 months ago #20177

Hello,

well, I am not 100% sure, but probably the EU vat check url has changed, as the script stopped working suddenly.

So I replaced the var $viesurl by new url var

$viesurl = 'ec.europa.eu/taxation_customs/vies/checkVatService.wsdl';

in euvatcheck.class.php (line 17)

and it is working again. So anybody who runs into troubles can try it.

Cheers,
Lenka
The topic has been locked.

Re: EU VAT ID check installation problem 13 years, 3 months ago #20191

Hi Lenka,

Thanks for posting! In case this happens again: how did you find out the right url?

Wouter
The topic has been locked.

Re: EU VAT ID check installation problem 13 years, 3 months ago #20193

Hi Wouter,

I found it by googeling:o) ...and testing. One of the urls I found got redirected to the current working one. Anyway I think that ARTIO could improve the script a little, as I only found out that the validation didnnt work, by customers complaining. An email to admin in case of validation failure would be a nice feature:)

Lenka
The topic has been locked.

Re: EU VAT ID check installation problem 13 years, 3 months ago #20198

Hi Lenka,

I was also thinking about an email alert. Now I have to check the log file for an error. And it is not an error message, but a debug message. I tried to change the debug message to an error message. But then the customer gets the error message. Not what I want.

I will try to add the email alert myself and keep you posted on the progress. Or can somebody from Artio provide the code to add?

Wouter
The topic has been locked.

Re: EU VAT ID check installation problem 13 years, 3 months ago #20199

Hi Wouter,

I totally agree with what you say: frontend message is not a good solution as the customer will be able to read it. That is why I was thinking of an e-mail alert, as the debug message eint handy at all.

Unfortunately I don´t think that this would be a priority for ARTIO, so “do it yourself” is probably the right attitude. If you do it first, please share :o)

Lenka
The topic has been locked.
Přihlášení uživatele Prázdný