Menu Content

Podpora

> Diskusní fóra, FAQs & placená podpora
Welcome, Guest
Username Password: Remember me

header returns 404 when link to page is correct?
(1 viewing) (1) Guest
  • Page:
  • 1
  • 2

TOPIC: header returns 404 when link to page is correct?

header returns 404 when link to page is correct? 12 years, 6 months ago #6180

hi, i've recently migrated our site over to Joomla 1.5; everything looked like it was running smoothly until our google webmaster tool reported about 1450 broken (404) links. We currently only have about 1280 indexed so I did some digging and found that the headers are somehow broken. Here's an example someone from another form pointed out to me -->


oyoy.eu/page/headers/?full=1&url=htt...content/view/130/60/

as you can see from the link; the page will pull up correctly however the header is returning a 404 error. How would I go about correcting this before our pages are de-indexed? Thanks in advance for your help, I'm seriously at a loss with how to correctly handle this.

edit:
thought it was also important that I mention the backlinks plugin has been enabled as well joomsef; both(appear?) to be functioning correctly

Re:header returns 404 when link to page is correct 12 years, 6 months ago #6182

starting to think joomsef is incorrectly setting the header to 404 for all my previous SEF links

www.nptechnews.com/content/view/130/60/

is a sef link set up via the default core SEF component in Joomla 1.0. It's able to find the content regardless via the legacy backlinks plugin yet for some reason the header is regarding this page as 404 despite the content being displayed.

Is there anyway to set up a universal redirect which will forward this article to the correct url? I find it hard to believe that we're the only ones who've experienced this issue.
Last Edit: 12 years, 6 months ago by SchweppesAle.

Re:header returns 404 when link to page is correct 12 years, 6 months ago #6184

  • jaku
Do you have the setting redirect non-sef to SEF URL on?

Re:header returns 404 when link to page is correct 12 years, 6 months ago #6189

yes, I've tried enabling that on the site in question.

All links generated via query strings are functioning correctly; however all legacy sef urls redirected via the backlinks plugin are returning a header of 404.

This has become a critical issue on not one, but two sites as google has marked well over 2000 of our urls as 404.
Last Edit: 12 years, 6 months ago by SchweppesAle.

Re:header returns 404 when link to page is correct? 12 years, 6 months ago #6191

for the record, this is absolutely being caused by the Joomsef component. I just disabled it for a few seconds and all the links I've just mentioned returned the correct 200 response.

Re:header returns 404 when link to page is correct? 12 years, 6 months ago #6197

  • dajo
  • OFFLINE
  • Posts: 5070
Hello,

We've been able to find and repair the problem, the fix will be included in next JoomSEF version. I've also sent the fixed file with instructions to use it to the e-mail you used for registration.

Best regards,
ARTIO Support Team
ARTIO Support Team
  • Page:
  • 1
  • 2
Přihlášení uživatele Prázdný