Menu Content

Support

> Forums, FAQs & Paid Support
Welcome, Guest
Username Password: Remember me

Fatal Error after upgrade to Joomla 3.3
(1 viewing) (1) Guest
Universal booking and reservations component for Joomla!.

NOTE: This category has been locked. If you have purchased paid version, please, use our Support Ticket system instead. If you are using free edition, please see the Community Support section.

TOPIC: Fatal Error after upgrade to Joomla 3.3

Fatal Error after upgrade to Joomla 3.3 8 years, 7 months ago #44178

Hi, my provider upgraded my Joomla version from 3.1.5 to 3.3..

Since the, the Book-it component (2.2) doesn't work any more. Only blank pages are shown in both frontend and backend. Displaying the pages in the error reporting mode, following fatal errors are reported:

FRONTEND:
Fatal error: Declaration of TableSubject::store() must be compatible with JTableInterface::store($updateNulls = false) in /home/weblicre/public_html/tulambenresidencech/portal/administrator/components/com_booking/tables/subject.php on line 644

BACKEND:
Fatal error: Declaration of TableReservation::bind() must be compatible with JTableInterface::bind($src, $ignore = Array) in /home/weblicre/public_html/tulambenresidencech/portal/administrator/components/com_booking/tables/reservation.php on line 312
The topic has been locked.

Re: Fatal Error after upgrade to Joomla 3.3 8 years, 7 months ago #44180

Hello!

I have same problem. What to do? I need working reservation system for my little business.
Matti
The topic has been locked.

Re: Fatal Error after upgrade to Joomla 3.3 8 years, 7 months ago #44181

Guys,

you are not alone. I am experiencing the same problem with another Artio product. From what I could understand, this is a major change introduced by J3.3 update requiring Artio developers to release a consistent products revision.
I wrote to their support as I wasn't even able to use a just-bough product so my website user's activities didn't even started. I was kinda of lucky as I can only figure out how many costumers are out there who are unable to run their business because of this problem.

Of course Artio could at least reply telling us what's going on...
The topic has been locked.

Re: Fatal Error after upgrade to Joomla 3.3 8 years, 7 months ago #44184

same problems for me, not running on 3.2.4 and not running on 3.3.0...
Hope they solve it quickly.
The topic has been locked.

Re: Fatal Error after upgrade to Joomla 3.3 8 years, 7 months ago #44185

Same problem here!
and not an answer yet!

any news from artio crew?
The topic has been locked.

Re: Fatal Error after upgrade to Joomla 3.3 8 years, 7 months ago #44187

  • jitr
  • OFFLINE
  • ARTIO Support
  • Posts: 1432
Hello, current versions of Booking 2 and JoomDOC 4 are incompatible with Joomla 3.2.4 and Joomla 3.3.0. We will fix them and release new version asap.
ARTIO Support Team
The topic has been locked.
User Login Empty