Menu Content

Support

> Forums, FAQs & Paid Support
Welcome, Guest
Username Password: Remember me

Meta Title not showing in back end - exists in htm
(1 viewing) (1) Guest
Support forum for customers who have purchased JoomSEF 4 (Joomla 1.6/1.7/2.5+ compatible). Archive only, no new post can be added.

NOTE: This category has been locked. If you have purchased paid version, please, use our Support Ticket system instead. If you are using free edition, please see the Community Support section.
  • Page:
  • 1

TOPIC: Meta Title not showing in back end - exists in htm

Meta Title not showing in back end - exists in htm 7 years, 10 months ago #41982

Hello,

When I look in the back end, in the "Manage Meta Tags" the first column "Meta Title" is empty for all my items. The actual HTML code shows Meta Titles, but I would like to be able to see them and edit them from the back end.

Artio 4.5.1
VM extension 3.0.18
Virtue Mart 2.0.24c
Joomla 2.5.16

Thanks
The topic has been locked.

Re: Meta Title not showing in back end - exists in htm 7 years, 10 months ago #42199

  • dajo
  • OFFLINE
  • Posts: 5070
Hi,

The default meta titles generated by Joomla are not visible in JoomSEF. You need to set up meta titles generation in JoomSEF's Configuration, so JoomSEF will generate its own meta titles that you can see in the Meta Tags Manager.
However, you can always set the meta titles in Meta Tags Manager to override the Joomla's default ones.
For more information about Meta Tags Configuration options please refer to JoomSEF's documentation: www.artio.net/joomsef/documentation
ARTIO Support Team
The topic has been locked.

Re: Meta Title not showing in back end - exists in htm 7 years, 10 months ago #42213

Thank you for your response.
I read the documentation, unfortunately it does not say much about the subject.

I had Meta-titles set up. i.e. Enable Meta Tags management: was set to Yes.
I changed "Metadata auto-generation:" from "Only if Original Empty" to "Always"
I had "Prefer JoomSEF titles:" set to Yes and it still is Yes.

On the "Manga Meta Tags" tab, the first column "Meta Title" is still blank.
How do I get the see the Meta Titles?

Thanks
The topic has been locked.

Re: Meta Title not showing in back end - exists in htm 7 years, 9 months ago #42306

You wrote me:


Dear Shimon,

The meta tags generation is controlled by each JoomSEF extension separately. For articles, the page title tag is generated only if you enable "Add category to page title" or "Add page number to page title" option in Content extension's parameters.
The "Metadata auto-generation" option in JoomSEF's Configuration controls whether the description or keywords tag is stored in database when the extension generates it. So if the extension doesn't generate the tag, it can't be stored even if the option is set to Always.
I'm sorry for the confusion.

With kind regards,

Jozefov David
ARTIO Support Team


I do not understand your response.
I am using the Virtuemart extension.
My problem is the Meta-titles I am not asking about articles. I am only interested in products in the Virtuemart store.

I do not see and parameters in the Virtuemart extension to allow me to see the meta-titles in the back end.
Please provide me with exact instructions what to check/set etc to get Meta titles.

Thanks
The topic has been locked.

Re: Meta Title not showing in back end - exists in htm 7 years, 9 months ago #42313

  • dajo
  • OFFLINE
  • Posts: 5070
Dear Shimon,

JoomSEF usually doesn't generate its own meta titles unless you select that you want different meta titles than the default ones in the extension's parameters.
For VirtueMart, go to JoomSEF -> Manage Extensions -> VirtueMart and on the Meta Tags tab set "Product page title" and "Category page title" options to something else than "Default". Then you will need to update the meta tags for already existing SEF URLs - use JoomSEF's URLs Manager and either use the Update Meta Tags action for your VirtueMart URLs, or delete your VirtueMart URLs and let them recreate altogether.

See the screenshots:

vm.jpg


update.jpg
ARTIO Support Team
The topic has been locked.
  • Page:
  • 1
User Login Empty