Menu Content

Support

> Forums, FAQs & Paid Support
Welcome, Guest
Username Password: Remember me

Problem with languages SEF4 + Virtuemart extension
(1 viewing) (1) Guest
Support forum for customers who have purchased JoomSEF 4 (Joomla 1.6/1.7/2.5+ compatible). Archive only, no new post can be added.

NOTE: This category has been locked. If you have purchased paid version, please, use our Support Ticket system instead. If you are using free edition, please see the Community Support section.
  • Page:
  • 1
  • 2

TOPIC: Problem with languages SEF4 + Virtuemart extension

Problem with languages SEF4 + Virtuemart extension 10 years, 4 months ago #29219

Hi,

I´m finishing the project you can see on planetate.es (right now it´s closed but if you can give a way to give you the user and password so you can go in and check what I am saying).

The problem is that when JoomSef4 it´s enabled, if you click on the language selector the content appears translated but not any menú or module.

PLEASE GIVE ME URGENT HELP! It´s the first time I try JoomSef4 on a Joomla 2.5 +Virtuemart2
The topic has been locked.

Re: Problem with languages SEF4 + Virtuemart extension 10 years, 4 months ago #29222

well... to go faster I entered an easy login and pass to get access to the front end and back end.
user -> admin
pass -> admin

I have copy from the hole joomla scripts + bbdd, but I hope nobody goes to make some damage :-)
I left the JomSEF4 enabled so everybody can check the error when changing languages (the content is translated but not the menu and module in left side).
I the JomSEF4 is disabled it works correctly (but with ugly urls)
The topic has been locked.

Re: Problem with languages SEF4 + Virtuemart extension 10 years, 4 months ago #29256

  • dajo
  • OFFLINE
  • Posts: 5069
Hi,
Please make sure that Language Filter plugin is disabled in Joomla and then that JoomSEF's Language management is enabled in JoomSEF's Configuration on the Language tab.
ARTIO Support Team
The topic has been locked.

Re: Problem with languages SEF4 + Virtuemart extension 10 years, 4 months ago #29264

Hi Dajo,

After disabling Joomla Language Filter plugin the tab "language" in the JoomSEF´s appeared (before with the joomla plugin enabled this option wasn´t visible)

Right now the JoomSEF´s language option is set to Yes and I´m still facing the same problem. When changing language the content of the article changes but the rest of modules doesn´t.
Do not know why but when updating the JoomSEF urls once I saw some Virtuemart urls changing correctly, but when doing the urls update again nothing was working at all again.

Please let me know what can be the problem coz otherwise I´m not gonna have a multilanguage store....
Use the access I gave you to access to the backend area if necessary to check the configurations.

Thanks in advance for all your help
The topic has been locked.

Re: Problem with languages SEF4 + Virtuemart extension 10 years, 4 months ago #29266

Dajo, I might been smoking too much lately. Problem solved! It was a mistake of mine :-)

Regards,
The topic has been locked.

Re: Problem with languages SEF4 + Virtuemart extension 10 years, 4 months ago #29267

Another question.
The default language of my site is Spanish. So JoomSef uses www.planetate.es/es for all the content in the main language.

There´s a posibility of to do not show the language in the url for all the contents done with the main language?

Thanks in advance for your help :-)
The topic has been locked.
  • Page:
  • 1
  • 2
User Login Empty