Menu Content

Support

> Forums, FAQs & Paid Support
Welcome, Guest
Username Password: Remember me

M-Turbo not caching All Pages
(1 viewing) (1) Guest
Support forum for customers who have purchased this product. Archive only, no new post can be added.

NOTE: This category has been locked. If you have purchased paid version, please, use our Support Ticket system instead. If you are using free edition, please see the Community Support section.
  • Page:
  • 1
  • 2

TOPIC: M-Turbo not caching All Pages

M-Turbo not caching All Pages 11 years, 1 month ago #39615

I recently purchased the full version of m-turbo. I have tried to cache all pages but more than a 3rd of them did not get cached. I saw errors like these in the output:

HTTP 404 | url: lighthousesupply.ca/home-lighting/3w-gu1...o_dynamic_block=true

I have caches pages with product listings containing products that link to product detail pages some that are cached and some that are not cached. It is annoying to have some pages cached and others that are not.

Another problem is the process doesn't work with cron. I have to log into a magento admin each time and do things manually which is time consuming and defeats the purpose of having the cron update functionality.

I would like to have these issues corrected so that my customers can good experience navigating my website.
The topic has been locked.

Re: M-Turbo not caching All Pages 11 years, 1 month ago #39621

  • jich
  • OFFLINE
  • Posts: 254
Hello Cyberopt,

The message HTTP 404 | url: ... means that URL is not available, thus page cannot be cached. I have put this URL into my browser and I've got Service Unavailable. It seems that you have set the maintenance flag there.

> I have caches pages with product listings containing products that link to product detail pages some that are
> cached and some that are not cached. It is annoying to have some pages cached and others that are not.

You can watch all cached pages on the tab URL in the M-Turbo administration. If you want to know whether a page with URL is cached. Put URL into the filter field "Request path" and let it search then you can see whether page is cached and how much sizes takes from your disk.

> Another problem is the process doesn't work with cron. I have to log into a magento admin each time and do
> things manually which is time consuming and defeats the purpose of having the cron update functionality.

Make sure that your webserver has permission to execute the script app/code/local/Artio/MTurbo/scripts/getstatichtml.sh. If not, change the permission, please.

If that script is executable then make sure that Magento cron scheduler is executing correctly. There may be a lot of issues. About the setup of the Magento cron can read for example here www.jnorton.co.uk/blog/how-correctly-con...re-magento-cron-job.

If you are not familliar with Magento cron, you can execute script app/code/local/Artio/MTurbo/scripts/getstatichtml.sh directly from shell. For more information www.artio.net/support-forums/m-turbo/cus...o-cache-all-with-ssh
ARTIO Support Team
The topic has been locked.

Re: M-Turbo not caching All Pages 11 years, 1 month ago #39622

Hi, thanks for getting back to me. please see my comments below.

>>The message HTTP 404 | url: ... means that URL is not available, thus page cannot be cached. I have put this >>URL into my browser and I've got Service Unavailable. It seems that you have set the maintenance flag there.

I had turned on the maintenance flag not too long ago to stop customers from viewing the website in the state it was in. the URLs that result in 404 were generated when I clicked on the Synchronize button. I can accept that the URLs are not available and the page cannot be cached. The question is why are these URLs appearing in the URL list?

> I have caches pages with product listings containing products that link to product detail pages some that are
> cached and some that are not cached. It is annoying to have some pages cached and others that are not.

>>You can watch all cached pages on the tab URL in the M-Turbo administration. If you want to know whether a >>page with URL is cached. Put URL into the filter field "Request path" and let it search then you can see whether >>page is cached and how much sizes takes from your disk.

I have done this before, and I do not see the URL of the page that is not cached in the list of URLs. I have emptied the cache pages and you are welcome to watch m-turbo in action on my website to see the results I am talking about. You will notice only about a 3rd of the pages are cached.

> Another problem is the process doesn't work with cron. I have to log into a magento admin each time and do
> things manually which is time consuming and defeats the purpose of having the cron update functionality.

>>Make sure that your webserver has permission to execute the script app/code/local/Artio/MTurbo/scripts/getstatichtml.sh. If not, change the permission, please.

I have done this and double checked many times already. the script is executable

>>If that script is executable then make sure that Magento cron scheduler is executing correctly. There may be a lot >>of issues. About the setup of the Magento cron can read for example here www.jnorton.co.uk/blog/how-correctly-con...re-magento-cron-job.

>>If you are not familliar with Magento cron, you can execute script app/code/local/Artio/MTurbo/scripts/getstatichtml.sh directly from shell. For more information www.artio.net/support-forums/m-turbo/cus...o-cache-all-with-ssh


I have run the script directly from shell and i still get the same results as I did when i run the cache all pages in the magento admin.
The topic has been locked.

Re: M-Turbo not caching All Pages 11 years, 1 month ago #39624

  • jich
  • OFFLINE
  • Posts: 254
I had turned on the maintenance flag not too long ago to stop customers from viewing the website in the state it was in. the URLs that result in 404 were generated when I clicked on the Synchronize button. I can accept that the URLs are not available and the page cannot be cached. The question is why are these URLs appearing in the URL list?


The URL list contains all possible URLs by your categories, products and CMS. You can think about this as a mirror of table "core_url_rewrite". There are placed URL which you wish be cached. M-Turbo cannot check that URL is correct when copying the URLs from "core_url_rewrte" to "mturbo" table. It would take a lot of time. If you know that URL is invalid you can delete it from list after synchronization or let it block.

have done this before, and I do not see the URL of the page that is not cached in the list of URLs. I have emptied the cache pages and you are welcome to watch m-turbo in action on my website to see the results I am talking about. You will notice only about a 3rd of the pages are cached.


If you do not see URL in the list of URLs then URL was not be copied from table "core_url_rewrite". Make sure that the category/product/cms is active, please. URL of inactive entity are not copied during synchronization. Teoretically there may be a URL collision with some user defined rewrites but it is very rarely situation. However, you can try to check whether missing URL is present in the grid in Catalog/URL Rewrite Management.

I have run the script directly from shell and i still get the same results as I did when i run the cache all pages in the magento admin.


Could you write the output of that operation? If you execute the script by shell then there should be the standard/error output. It could tell us what is wrong and help us to debug it.
ARTIO Support Team
Last Edit: 11 years, 1 month ago by jich.
The topic has been locked.

Re: M-Turbo not caching All Pages 11 years, 1 month ago #39625

The URL list contains all possible URLs by your categories, products and CMS. You can think about this as a mirror of table "core_url_rewrite". There are placed URL which you wish be cached. M-Turbo cannot check that URL is correct when copying the URLs from "core_url_rewrte" to "mturbo" table. It would take a lot of time. If you know that URL is invalid you can delete it from list after synchronization or let it block.

This could be the issue here. When I look at some of the urls in core_url_rewrite table to list urls in m-turbo list I can see some do not match. There are over 3000 urls in the list so comparing one by one would be inefficient.

If you do not see URL in the list of URLs then URL was not be copied from table "core_url_rewrite". Make sure that the category/product/cms is active, please. URL of inactive entity are not copied during synchronization. Teoretically there may be a URL collision with some user defined rewrites but it is very rarely situation. However, you can try to check whether missing URL is present in the grid in Catalog/URL Rewrite Management.

category/product/cms is active

Could you write the output of that operation? If you execute the script by shell then there should be the standard/error output. It could tell us what is wrong and help us to debug it.

This is the command i used to run the script in the shell:

/bin/sh /home/lighthou/public_html/app/code/local/Artio/MTurbo/Model/scripts/getstatichtml.sh var/turbocache/base.txt

I don't see any output once it is finish running. is there another command to use?
The topic has been locked.

Re: M-Turbo not caching All Pages 11 years, 1 month ago #39630

  • jich
  • OFFLINE
  • Posts: 254
This could be the issue here. When I look at some of the urls in core_url_rewrite table to list urls in m-turbo list I can see some do not match. There are over 3000 urls in the list so comparing one by one would be inefficient.


I don't think. There is suppose that the records in "core_url_rewrite" are valid. It has no sense to have invalid URL there. If you have a lot of invalid URL you can try to reindex Core URL Rewrite Index in the index management.

category/product/cms is active


You can check whether the correspond storeview is enabled on tab "Website Configuration", else you can send me credentials to admin at This e-mail address is being protected from spambots. You need JavaScript enabled to view it , I would investigate this in place.

This is the command i used to run the script in the shell:

/bin/sh /home/lighthou/public_html/app/code/local/Artio/MTurbo/Model/scripts/getstatichtml.sh var/turbocache/base.txt

I don't see any output once it is finish running. is there another command to use?


You should use the absolute path to base.txt.

/bin/sh /home/lighthou/public_html/app/code/local/Artio/MTurbo/Model/scripts/getstatichtml.sh /home/lighthou/public_html/var/turbocache/base.txt
ARTIO Support Team
The topic has been locked.
  • Page:
  • 1
  • 2
Moderators: pedu
User Login Empty