Menu Content

Support

> Forums, FAQs & Paid Support
Welcome, Guest
Username Password: Remember me

Problem with Dynamic Blocks again
(1 viewing) (1) Guest
Support forum for customers who have purchased this product. Archive only, no new post can be added.

NOTE: This category has been locked. If you have purchased paid version, please, use our Support Ticket system instead. If you are using free edition, please see the Community Support section.

TOPIC: Problem with Dynamic Blocks again

Re: Problem with Dynamic Blocks again 11 years, 6 months ago #34448

  • jich
  • OFFLINE
  • Posts: 254
Hello Dustin,

We know about these issues. We are planning fix them in the next release. For now, you try to fix it with follow files. Extract them and copy to your site:

mturbo.js - skin/frontend/base/default/js and skin/frontend/default/default/js/
IndexController.php - app/code/local/Artio/Mturbo/controllers/

File Attachment:

File Name: IndexController.php.zip
File Size: 2 KB


File Attachment:

File Name: mturbo.js.zip
File Size: 1 KB


The fixes will resolve problem with invalid HTML (tag <block>). However, the HTML tag <div id="cartsidebar"> is required for inserting the block onto right place.
ARTIO Support Team
The topic has been locked.

Re: Problem with Dynamic Blocks again 11 years, 6 months ago #34451

I just updated my theme to the latest version, so I had to apply all the fixes again.
I get everything to work, except the drop down menu from the cart in the header.

The drop down is just not there in any of the cached pages, but if you look at gdx.no/checkout/cart/ or gdx.no/checkout/onepage/ (After adding one product to the cart) you will see the drop down showing the content of the cart.
The topic has been locked.

Re: Problem with Dynamic Blocks again 11 years, 6 months ago #34465

  • DR
  • OFFLINE
  • Posts: 3
Hi jich,

thanks, however I realized that the whole cart html is different. Well, GDX.no seems to have it working now, so I did what you suggested to him, namely

I renamed the header cart block "cart_sidebar" to "cart_sidebar_header" and set it in the M-Turbo administration (tab Dynamic loaded blocks)

But somehow that doesn't work for me. I compared his html to mine and e.g. the javascript under the cart html looks different.

His JS:

 
//<![CDATA[
function fillBlockcart_sidebar_header() {
if (typeof(mturboloader)!='undefined') {
mturboloader;
if (mturboloader.complete) {
document.getElementById('cart_sidebar_header').innerHTML = mturboloader.getBlock('cart_sidebar_header');
} else {
setTimeout('fillBlockcart_sidebar_header()', 100);
}
}
}
fillBlockcart_sidebar_header();
//]]>
 


My javascript:

 
//<![CDATA[
function fillBlockcartsidebar() {
if (typeof(mturboloader)!='undefined') {
mturboloader;
if (mturboloader.complete) {
document.getElementById('cartsidebar').innerHTML = mturboloader.getBlock('cartsidebar');
} else {
setTimeout('fillBlockcartsidebar()', 100);
}
}
}
fillBlockcartsidebar();
//]]>
 


So on his site it's correctly using 'cart_sidebar_header' but not on mine. If I change mturboloader.getBlock('cartsidebar'); manually to mturboloader.getBlock('cart_sidebar_header'); via FireBug the cart div only gets filled with "undefined".

What have I forgotten resp. what is wrong?

Thanks !!!!!
The topic has been locked.

Re: Problem with Dynamic Blocks again 11 years, 6 months ago #34467

  • DR
  • OFFLINE
  • Posts: 3
Jich, sorry for my last post, please ignore it, I found the solution!

I also had to set

Cart Block (sidebar): No

in MTurbo Admin.

Now it's perfect.

Thanks!
The topic has been locked.
Moderators: pedu
User Login Empty