Menu Content

Podpora

> Diskusní fóra, FAQs & placená podpora
Welcome, Guest
Username Password: Remember me

Warning: Invalid argument supplied for foreach() i
(1 viewing) (1) Guest
Universal booking and reservations component for Joomla!.

NOTE: This category has been locked. If you have purchased paid version, please, use our Support Ticket system instead. If you are using free edition, please see the Community Support section.

TOPIC: Warning: Invalid argument supplied for foreach() i

Re: Warning: Invalid argument supplied for foreach() i 7 years ago #34247

ok, the warning won't be shown anymor by editig the code the way you've shown. But there is another problem: it's not possible to safe any changes in the configuration. It says "Save failed" - without any further information?

First I thought it's caused by the problem caused that warning - but now the warning is gone, but saving fails anyway.

Thanks for help!
The topic has been locked.

Re: Warning: Invalid argument supplied for foreach() i 7 years ago #34253

  • maju
  • OFFLINE
  • Posts: 1108
Hello,

that problem is only in Configuration page? What about logs? Is there anything about your problem with saving?
I tested it with actual version of Booking and I have no problems with saving configuration.
ARTIO Support Team
The topic has been locked.

Re: Warning: Invalid argument supplied for foreach() i 7 years ago #34263

yes, only in the Configuration page. Here is the part from Logging my try to change Config:

EDIT by admin: Logs copied and removed from this POST
Last Edit: 7 years ago by maju. Reason: Logs copied and removed from this POST
The topic has been locked.

Re: Warning: Invalid argument supplied for foreach() i 7 years ago #34267

  • maju
  • OFFLINE
  • Posts: 1108
Hello,

that was access.log and it showed me nothing special. What about error.log? There is nothing about problem with saving config?
ARTIO Support Team
The topic has been locked.

Re: Warning: Invalid argument supplied for foreach() i 7 years ago #34268

well, it seems during the installation went something wrong: there is no config-table in the database (found that error by running the site in debug-modus)

Now I've tried to uninstall the component, but that won't work cause of the missing database-table :(
I will try again in the evening when my time is not so rare...


part of the error-log:

EDIT by admin: Logs copied and removed from this POST
Last Edit: 7 years ago by maju. Reason: Logs copied and removed from this POST
The topic has been locked.

Re: Warning: Invalid argument supplied for foreach() i 7 years ago #34270

  • maju
  • OFFLINE
  • Posts: 1108
Ok, I can not find this table in installation script.

Can you try execute this SQL in your phpmyadmin and then try to save config? Do not forget to change your prefix '#_'.

CREATE TABLE IF NOT EXISTS `#__booking_config` (
`id` int(11) NOT NULL AUTO_INCREMENT,
`key` varchar(100) NOT NULL,
`value` varchar(5000) DEFAULT NULL,
PRIMARY KEY (`id`),
UNIQUE KEY `key` (`key`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8 AUTO_INCREMENT=1;
ARTIO Support Team
The topic has been locked.
Přihlášení uživatele Prázdný