Menu Content

Podpora

> Diskusní fóra, FAQs & placená podpora
Welcome, Guest
Username Password: Remember me

excluding a specific URL from using SEF
(1 viewing) (1) Guest
Support forum for users using free edition of JoomSEF 3 (Joomla 1.5 compatible). These forums are mainly for mutual help between users.

Please note that due to our capacity limitations, we do not monitor these forums regularly.
  • Page:
  • 1
  • 2

TOPIC: excluding a specific URL from using SEF

excluding a specific URL from using SEF 11 years, 10 months ago #5464

I'm using Joomla 1.5.8 and have JoomSEF v3.2.1 installed. It works wonderfully on all my pages but one. I have a FAQ page that uses javascript to allow a link to be clicked (the question) then a box to drop down with the answer. The page has html tags around it, and JoomSEF seems to be stripping those off (it works fine with SEF turned off). I tried defining my own redirect to get it to skip using SEF on that page, but it's still stripping that tag off so simply redirecting/defining isn't working. That page is an individual page and not a component or module so it's not defined in the configuration area where I could simply select skip. Is there any way to get it to skip that page individually so that it won't strip the html off the code?

Re:excluding a specific URL from using SEF 11 years, 10 months ago #5465

  • miun
  • OFFLINE
  • A pesimist is just a well-informed realist.
  • Posts: 563
Hi,
could you please paste here the example of the code how it looks before and after the "stripping"?
In general JoomSEF looks for URLs starting with index.php?.... and turns those into the SEO ones.
ARTIO Support Team

Re:excluding a specific URL from using SEF 11 years, 10 months ago #5466

I'm revisiting a old issue I don't know if it has been resolved. I'm using a Wordpress blog in a /blog directory. I have created a link to it in the mainmenu and it comes up fine, but trying to access any of the pages of the blog triggers a 404 page to come up. Is there a way in Artio SEF to tell it to exclude the /blog directory and just let the Wordpress code handle all of the SEO rewrites and permalinks etc. My blog is basically broken except for the Main page. I just recently upgraded to Joomla 1.5.8 and Artio SEF. I saw this issue brought up in a post 5 months ago but did not find a resolution in the thread.

Many Thanks

Karl

Re:excluding a specific URL from using SEF 11 years, 10 months ago #5467

The code I am referring to is placed into an article. The address for it without SEF does begin with index.php?.

The code before is something like this.
<html>
.menutitle{
cursor:pointer;
margin-bottom: 5px;
background-color: black;
color: dodgerblue;
width: 750px;
padding:2px;
text-align:left;
font-weight:normal;
}
 
.submenu{
margin-bottom: 0.5em;
}
 
......
 
</html>
 


Afterward, the html tag is completely removed (why I said stripped), and just looks like this.
 
.menutitle{
cursor:pointer;
margin-bottom: 5px;
background-color: black;
color: dodgerblue;
width: 750px;
padding:2px;
text-align:left;
font-weight:normal;
}
 
.submenu{
margin-bottom: 0.5em;
}
 


Is there any way to get it to exclude that specific article or will I need to try uploading it as an individual page without the index.php? in the URL?

Re:excluding a specific URL from using SEF 11 years, 10 months ago #5468

I'm not sure what has happened, but now my blog is working just fine. I can't explain why. I did create a subdomain blog.seoexpertpro.com but I am not pointing the blog to it and it doesn't work anyway.

Re:excluding a specific URL from using SEF 11 years, 10 months ago #5469

I figured out how to fix the problem. Instead of just pasting the code into the article itself (which worked fine without SEF enabled), I went to my module manager and created a custom module, putting the code into the "Custom Output" box and typing in a custom position in the position box. I then went back to the article I wanted it to be in and put "{loadposition myposition}" with myposition being the custom position I manually typed in. I hit save, then went and purged the SEF links. When the links were all re-saved after reconfiguring, my code showed up correctly. Now the SEF url will work correctly, and the page shows up too. So I didn't actually end up having to exclude the URL itself.
  • Page:
  • 1
  • 2
Přihlášení uživatele Prázdný