Hello,
this is quite strange. Are you using JoomFish? It seems the JoomSEF is unable to load the correct category (or menu title) for the first part of the URL.
Also, there could be a problem in the JoomSEF configuration -- see what value is filled next to the VirtueMart component name in the configuration (by defaullt, it should be empty and the checkbox unchecked).
Also, please, check the settings for the VM plug-in: go in list of installed JoomSEF plug-ins and click the VM extensions. Try to adjust the category / section options.