Menu Content

Podpora

> Diskusní fóra, FAQs & placená podpora
Welcome, Guest
Username Password: Remember me

having problem after upgraded artio
(1 viewing) (1) Guest
  • Page:
  • 1

TOPIC: having problem after upgraded artio

having problem after upgraded artio 9 years, 10 months ago #11508

i migrated my main site over from joomla 1.0 to joomla 1.5 and the 1.0 site was using artio 2.x (i installed artio 3.x onto my joomla 1.5 site) --- so i exported the urls from the artio 2.x component and then imported them into the artio 3.x component on the 1.5 site --- my problem is this: in the artio 2.x component there is a setting in configuration under the advanced tab, rewriting mode, with a dropdown list (without .htaccess (index.php), with .htaccess (mod_rewrite), without .htaccess (index.php?)). The choice we had selected on the old version was without .htaccess (index.php) which caused an index.php to be inserted into every url after site name (before rest of url string) for example: mysite.com/index.php/article --- when i imported all of the sef urls, they imported fine and appear without the index.php; however, because google has indexed them, my boss wants to keep the same urls as we had WITH the index.php in there. i looked for the rewriting mode with dropdown in artio 3.x in order to insert the index.php back into all urls, but cant find that option and am not sure how to make this happen.

please help!

Re: having problem after upgraded artio 9 years, 2 months ago #18863

  • jaku
  • OFFLINE
  • Posts: 2697
Hello,
to the extent of my knowledge, JoomSEF always required the .htaccess (mod_rewrite) to be active.
If you had index.php in your links then it means JoomSEF was not active.

I think the best solution would be having the URLs without index.php and setting up a general redirect rule for this, that would redirect all ..index.php/xxx URLs to just /xxx.
ARTIO Support Team
  • Page:
  • 1
Přihlášení uživatele Prázdný