Menu Content

Support

> Forums, FAQs & Paid Support
Welcome, Guest
Username Password: Remember me

Labels missing from chart.
(1 viewing) (1) Guest
Flash chart component for Joomla CMS.

NOTE: This category has been locked. If you have purchased paid version, please, use our Support Ticket system instead. If you are using free edition, please see the Community Support section.
  • Page:
  • 1
  • 2

TOPIC: Labels missing from chart.

Labels missing from chart. 7 years, 5 months ago #36163

When I use a Single series Column 2D chart, the labels in my data show up, when I use a Single Series Bar 2D Chart the labels no longer show up.

See below



The topic has been locked.

Re: Labels missing from chart. 7 years, 5 months ago #36170

  • maju
  • OFFLINE
  • Posts: 1108
Hello,

as you can see in our demo site, there are labels visible for free and paid version.
demo.tramin.artio.cz/joomla25/en/bar-cha...bar-2d-and-3d-charts

Do you have set in Functional Attributes: Show Labels to 'Yes'?
ARTIO Support Team
The topic has been locked.

Re: Labels missing from chart. 7 years, 5 months ago #36173

Yes, in the functional attributes tab 'Show Labels' is set to YES.

I have uninstalled the 4 ARTIO extensions, cleared the cache and reinstalled. Still the same problem and I have a suspicion that some parts of the Free version are still installed, because the Single Series Bar 2D Chart when creating a new chart look like Free version bars, not like the enhanced Commercial version looks as shown in your link.

Creating a new Bar 2D chart, setting Show Labels to YES and rendering with the sample data shows no labels. Changing the Type to Column 2D and rendering the chart shows the labels.

Is there a way to force a complete uninstall of remnants from the Free content and a complete reinstall of all the content from the commercial version?

The picture below shows when creating a new chart. Is it complete in the content types available in the User version? Are the circled types correct in their display?

Last Edit: 7 years, 5 months ago by Harm Millaard.
The topic has been locked.

Re: Labels missing from chart. 7 years, 5 months ago #36187

Value Padding in Chart Padding & Margins does not seem to work either.
The topic has been locked.

Re: Labels missing from chart. 7 years, 5 months ago #36218

  • maju
  • OFFLINE
  • Posts: 1108
Hello,

it looks really like there is still something from free version. You can uninstall your component with Joomla Extension Manager. Then you should remove these folders:

components/com_artiofusioncharts
administrator/components/com_artiofusioncharts

Then check database and for sure remove tables starting with: {prefix}_artiofusioncharts

For full uninstallation you can also remove 2 plugins for charts. Content - ARTIOFusionCharts and Editor Button - ARTIOFusionCharts.

It should be prepared for new installation now. Let us know about result.
ARTIO Support Team
The topic has been locked.

Re: Labels missing from chart. 7 years, 5 months ago #36229

Followed all your steps, uninstalled from Extension Manager, checked for the plug-ins, they were no longer there, checked with Filezilla to see if the directories were removed, emptied the {prefix}_artiofusioncharts table so all my old charts were gone. Then reinstalled the 'User' version.

Next I created a new chart and the problem persists. Like previously no problems with the Pie 2D charts, but the Bar 2D charts give me problems. Unfortunately, my host is doing maintenance, so I can't access the MySQL database currently to check the XML code in the chart records, but some older Bar 2D charts show no problem with labels, but all persist in the 'Free' look, not the enhanced look of the 'User' or commercial version.

On this page ppbm7.com/index.php/final-results?showall=&start=2 you will see the Column 2D chart that still lacks the 'enhanced' look, but on this page ppbm7.com/index.php/the-price-tag you will see the 'enhanced' look in the Pie 2D charts.

Note that the first chart is using a real time MySQL link to update the data dynamically, something technically impossible with the 'Free' version.
The topic has been locked.
  • Page:
  • 1
  • 2
User Login Empty