Menu Content

Support

> Forums, FAQs & Paid Support
Welcome, Guest
Username Password: Remember me

ListBingo SEF always links to home page
(1 viewing) (1) Guest
Support forum for users using free edition of JoomSEF 3 (Joomla 1.5 compatible). These forums are mainly for mutual help between users.

Please note that due to our capacity limitations, we do not monitor these forums regularly.
  • Page:
  • 1
  • 2

TOPIC: ListBingo SEF always links to home page

Re: ListBingo SEF always links to home page 9 years ago #30377

  • dajo
  • OFFLINE
  • Posts: 5072
Hi,
Open JoomSEF's URLs Manager and find the "clinical-psychologist/karen-berger" SEF URL generated for ListBingo. Please post its associated Real non-SEF URL, so I can check if there's any problem with it.
ARTIO Support Team

Re: ListBingo SEF always links to home page 9 years ago #30384

Before doing this I deleted all the URL's just to be sure we were clean.

The SEF URL is www.alliedpages.co.za/professional-categ...ologist/karen-berger
The Normal URL is www.alliedpages.co.za/index.php?option=c...s.view&Itemid=48

I always get 500 Internal Server Error.

I would like to note that i am struggling with JoomSEF and the Listbingo addon. I think its best to try first get Joomsef to work on its own. Once that works I will try get the Plugin to work.

I am also using the free version of Joomsef, but agree to buy it if I can get it to work.

I am happy to show my .htaccess file or whatever else is required

Re: ListBingo SEF always links to home page 9 years ago #30385

Here is my .htaccess file which i have 777 permissions (as supplied to me by Listbingo Support)

DirectoryIndex index.php
RewriteEngine On
RewriteBase /lb14/lb14

########## Begin - Rewrite rules to block out some common exploits
## If you experience problems on your site block out the operations listed below
## This attempts to block the most common type of exploit `attempts` to Joomla!
#
## Deny access to extension xml files (uncomment out to activate)
#<Files ~ "\.xml$">
#Order allow,deny
#Deny from all
#Satisfy all
#</Files>
## End of deny access to extension xml files
# Block out any script trying to set a mosConfig value through the URL
RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|\%3D) [OR]
# Block out any script trying to base64_encode crap to send via URL
RewriteCond %{QUERY_STRING} base64_encode.*\(.*\) [OR]
# Block out any script that includes a <script> tag in URL
RewriteCond %{QUERY_STRING} (\<|%3C).*script.*(\>|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
# Send all blocked request to homepage with 403 Forbidden error!
RewriteRule ^(.*)$ index.php [F,L]
#
########## End - Rewrite rules to block out some common exploits

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !^/index.php
RewriteCond %{REQUEST_URI} (/|\.php|\.html|\.htm|\.feed|\.pdf|\.raw|/[^.]*)$ [NC]
RewriteRule (.*) index.php
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
Last Edit: 9 years ago by jonathanberger.

Re: ListBingo SEF always links to home page 9 years ago #30400

  • dajo
  • OFFLINE
  • Posts: 5072
Yes, the 500 Internal server error is usually associated to some problem with .htaccess file.
From the SEF URL you supplied it seems that your Joomla installation is in the root directory of the web server, but you have /lb14/lb14 set as RewriteBase in your .htaccess.
Try changing the RewriteBase line in your .htaccess file to:
RewriteBase /

If that doesn't help, try removing the "DirectoryIndex index.php" line from the .htaccess file.
ARTIO Support Team

Re: ListBingo SEF always links to home page 9 years ago #30403

Thanks for your reply.

This is the top of the .htaccess file now.

#DirectoryIndex index.php
RewriteEngine On
RewriteBase /

I now only get 404 errors whether #DirectoryIndex index.php is on or off.

i have asked my web host and they say everything should work.

I am getting frustrated. Is the best option to pay for support and get someone to install this for me?

Would love to get this working today.

Re: ListBingo SEF always links to home page 9 years ago #30407

  • dajo
  • OFFLINE
  • Posts: 5072
First try using the default Joomla htaccess file - just rename the htaccess.txt to .htaccess in your Joomla directory.
If it doesn't work with it, purchasing the installation service will probably be the easiest solution: www.artio.net/e-shop/joomsef/joomsef-ins...stallation-on-apache
ARTIO Support Team
  • Page:
  • 1
  • 2
User Login Empty