Menu Content

Support

> Forums, FAQs & Paid Support
Welcome, Guest
Username Password: Remember me

Artio JoomSEF killed my Joomla website
(1 viewing) (1) Guest
Support forum for users using free edition of JoomSEF 4 (Joomla 1.6/1.7/2.5+ compatible). These forums are mainly for mutual help between users.

Please note that due to our capacity limitations, we do not monitor these forums regularly.
  • Page:
  • 1
  • 2

TOPIC: Artio JoomSEF killed my Joomla website

Artio JoomSEF killed my Joomla website 2 months ago #82845

I am using Joomla v3.9 and Artio JoomSEF 4 free, both since several years since three days I have serious problems with this combination. Here is my site (it's a private family website for our house renovations): mona-stefan.de
https://abload.de/thumb/snipping_0459tk2t.jpeg


I don't know which option I changed in the last few weeks but now JoomSEF killed my website by creating thousands of URLs which
1. are not working
2. litter the database
3. creates lots of empty database querries which kill the MySQL instance of my webhost.


I first found the not-functional urls into the redirect-component of Joomla


they mostly begin with a "selbstbauprojekt-lautsprecher" in the first part of the url (which is an existing article) and followed by the url of another, second article. So this combined URLs do not work and therefore they appear with an error 404 into the redirect-component


then I found the origin of this false URLs into JoomSEF


five days ago JoomSEF had 47.867 urls and all worked fine, but nevertheless I startet a topic into the German Joomla bulletin board here


but now, JoomSEF created over 124.383 urls which enlarges the size of the database enormous and now let the MySQL instance collapse.
https://abload.de/thumb/snipping_049zlkfq.jpeg


Although I deactivated the creation of new SEF URLs in the control panel of JoomSEF the MySQL collapses again within 30 minutes after every restart
https://abload.de/thumb/snipping_046dak73.jpeg

now I did four changes at the system. I don't know exactly which was the right option but now the site is accessible and I can search for the problem. My changes are:
  • Redirect nonSEF URLs to SEF? -> no
  • Parse Joomla SEO links? -> no
  • Debugging URL errors -> no
  • via FTP in components -> com_sef -> controller I renamed the cron.php because I think that with this JoomSEF is crawling for new URLs

https://abload.de/thumb/snipping_047krjkt.jpeg



So did anybody has a similar problem and / or an idea how to solve this?
And how can I get rid of this masses of defective URLs into my database?

Thanks and regards
Stefan
Germany

Re: Artio JoomSEF killed my Joomla website 1 month, 2 weeks ago #82940

I have been using Joomsef for many years in the commercial version. Nothing better has emerged so far.
Your problem is not the fault of the component, but your wrong configuration.

The garbage in the database is created because you have not applied the appropriate filters. You should block page pagination, sorting, etc.

In the settings of each component there is "Variables filtering" - there you can block unnecessary dynamic functions that appear in the links

regards,
Krzysiek
piekielko.com
Last Edit: 1 month, 2 weeks ago by hazael.

Re: Artio JoomSEF killed my Joomla website 4 weeks ago #83029

@ Bigham: as I wrote above this is no solution because with just uninstalling Artio the whole site will crash because the created links are not working any more.

You should block page pagination, sorting, etc.

In the settings of each component there is "Variables filtering" - there you can block unnecessary dynamic functions that appear in the links


where to apply these settings?

Re: Artio JoomSEF killed my Joomla website 4 weeks ago #83030

You don't need to uninstall anything

Go to JoomSEF "301 Redirects Manager" settings:
/administrator/index.php?option=com_sef&controller=movedurls

Clear all links from the list, because at the moment the page may be in a loop

Remove dynamic parameters from links such as sorting, pagination and other types of filtering. It is unnecessary.
This will reduce the load on the database
Last Edit: 4 weeks ago by hazael.

Re: Artio JoomSEF killed my Joomla website 4 weeks ago #83033

hazael wrote:
You don't need to uninstall anything

Go to JoomSEF "301 Redirects Manager" settings:
/administrator/index.php?option=com_sef&controller=movedurls

Clear all links from the list, because at the moment the page may be in a loop


it seems that there are many redirects from Artio SEF urls to normal Joomla URLs
100 entries per page, 85 pages = 8.500 redirects...

And you are sure that this will not break my website if I clear these links? What about the menues or pagebreak-links or article ancors or just internal links I build by copying links of articels and inserted into another articel?



hazael wrote:

Remove dynamic parameters from links such as sorting, pagination and other types of filtering.

sorry but I still don't know where to find such settings :-(

Re: Artio JoomSEF killed my Joomla website 4 weeks ago #83036

Stefanseiner wrote:

And you are sure that this will not break my website if I clear these links? What about the menues or pagebreak-links or article ancors or just internal links I build by copying links of articels and inserted into another articel?


301 redirect links are generated automatically when you manually change and save the default SEF URL. This is useful for old addresses already indexed in search engines.
If these are new links, there is no point in generating them. Duplicate redirects to the same address can cause loops. at first, it is safe to delete all 301 addresses

Stefanseiner wrote:

sorry but I still don't know where to find such settings :-(


In the global settings of the Joomsef component or directly in the "SEF Extension":
Find the field in the form named "Custom non-SEF variables".
There, enter unnecessary variables from the addresses of the selected component - each one is separated by a semicolon
Such variables will not be added to the database as SEF friendly links

Exemplary variables for the Virtuemart component:
orderby;gclid;error;addrtype;virtuemart_user_id[0];new;task;order_pass;order_number;cid;type;view=product;showall;view=vmplg;page=2;on=;view=orders;layout=details;layout=edit

Exemplary variables for the K2 component:
limitstart;commentID;year;type;format;month;

-----------------------------

You can also block the generation of the entire URL address if it contains any variables you specify.
In the SEF extension settings in the field named "Do not SEF URLs matching regular expression"

Exemplary variables for the K2 component:
task=(checkin|content|calendar|date) | view=(article|user) | fb_locale= | cid=

Exemplary variables for the Virtuemart component:
keyword|layout=notify|view=manufacturer|view=ratings|view=media
  • Page:
  • 1
  • 2
User Login Empty