Menu Content

Support

> Forums, FAQs & Paid Support
Welcome, Guest
Username Password: Remember me

category still showing in url
(1 viewing) (1) Guest
Support forum for users using free edition of JoomSEF 4 (Joomla 1.6/1.7/2.5+ compatible). These forums are mainly for mutual help between users.

Please note that due to our capacity limitations, we do not monitor these forums regularly.
  • Page:
  • 1

TOPIC: category still showing in url

category still showing in url 7 years, 4 months ago #45071

  • wicko
  • OFFLINE
  • Posts: 65
I have installed artio sef into my site, set the content extension not to display category in url and then purged urls and cleared cache.

But when I browse to the site pages the category is still being displayed in my urls.

How can I stop the category showing in the url?

My site is site

Re: category still showing in url 7 years, 4 months ago #45072

  • dajo
  • OFFLINE
  • Posts: 5070
Hi,

The first part of the SEF URL may also be the menu title. Open Content extension's parameters in JoomSEF and on the Common tab disable the "Add menu title to URL" option.
Make sure to delete the old SEF URLs in JoomSEF's URLs Manager and clear the caches in Joomla and JoomSEF.

The problem may also be that the Purge URLs function doesn't delete locked and custom URLs, so they might have stayed there.
ARTIO Support Team

Re: category still showing in url 7 years, 4 months ago #45074

  • wicko
  • OFFLINE
  • Posts: 65
I have changed the content/extension to not display category in url and also disabled add name to url in the common tab. Then purged urls and cleared both sef cache and joomla cache but the urls are still the same.

If I look at the urls manager I don't see any urls that are locked.

Is there anything else I should set or clear to fix this?

Re: category still showing in url 7 years, 4 months ago #45083

  • dajo
  • OFFLINE
  • Posts: 5070
Hi,

Please follow these steps:
1. Make sure that everything is enabled in JoomSEF's Control Panel in the SEF Status box
2. Open Joomla's Plugin Manager and filter only plugins of type "system", make sure that System - ARTIO JoomSEF plugin has the lowest Ordering - it must be ordered as the first system plugin
3. Open JoomSEF's URLs Manager and in the toolbar select "All Filtered" and "Delete" in the selecto boxes, then click the "Proceed" button - all the SEF URLs should be deleted
4. In JoomSEF's Control Panel on the Maintenance tab click the "Clear Cache" button

Open your website in the browser and check if the URLs get regenerated correctly. If they don't, open JoomSEF's URLs Manager and post some example of the incorrect SEF URL and its Real URL. Also please post a screenshot of your Content extension parameters settings.
ARTIO Support Team

Re: category still showing in url 7 years, 4 months ago #45085

  • wicko
  • OFFLINE
  • Posts: 65
This appears to have solved the issue. Thank you for helping fix this.
  • Page:
  • 1
User Login Empty