Menu Content

Support

> Forums, FAQs & Paid Support
Welcome, Guest
Username Password: Remember me

Problem with itemid been added to url
(1 viewing) (1) Guest
Support forum for customers who have purchased JoomSEF 3 (Joomla 1.5 compatible). Archive only, no new post can be added.

NOTE: This category has been locked. If you have purchased paid version, please, use our Support Ticket system instead. If you are using free edition, please see the Community Support section.
  • Page:
  • 1
  • 2

TOPIC: Problem with itemid been added to url

Problem with itemid been added to url 12 years, 2 months ago #27556

This one is bizarre and no matter how hard I search I cannot find remedy. If you visit www.birdiesgardenproducts.com.au and navigate to Raised Garden Beds > Standard Garden Beds then from the full listing page click on the more 'Products details' link you'll see it returns a page not found error. I can see the problem with the url is it adds 'Itemid=100009' to the end when it is not required. It is only this link doing this though as everything else from that menu (which link to virtuemart categories) works fine. Any ideas?
The topic has been locked.

Re: Problem with itemid been added to url 12 years, 2 months ago #27606

  • dajo
  • OFFLINE
  • Posts: 5069
Hi,
This is really strange. What versions of Joomla, JoomSEF, VirtueMart component and VirtueMart JoomSEF extension do you use?
Is it possible that your VirtueMart's template adds the Itemid to product details URLs?
ARTIO Support Team
The topic has been locked.

Re: Problem with itemid been added to url 12 years, 2 months ago #27663

Got to be honest I've used your extension a number of times with joomla ansd virtuemart and never had a problem. It can't be the virtuemart template as it only happens on that section??? Versions in use :


  • Joomla: Version 1.5.25
  • VirtueMart 1.1.9 stable
  • ARTIO JoomSEF Version: 3.9.3
  • ARTIO Virtuemart JoomSEF extension 2.1.0


Cheers
Martin
The topic has been locked.

Re: Problem with itemid been added to url 12 years, 2 months ago #27701

  • dajo
  • OFFLINE
  • Posts: 5069
This is really strange. Try disabling the Cookie check in VirtueMart, it is sometimes causing really weird behaviour.
ARTIO Support Team
The topic has been locked.

Re: Problem with itemid been added to url 12 years, 1 month ago #27796

sorry no different there! still returning url www.birdiesgardenproducts.com.au/standar...mm-highItemid=100009 where if you delete the 'Itemid=100009' it works fine. Only still happening on that section as well?
The topic has been locked.

Re: Problem with itemid been added to url 12 years, 1 month ago #27810

  • dajo
  • OFFLINE
  • Posts: 5069
I'm sorry, but I don't know what could cause this. Try clearing Joomla and JoomSEF caches and also deleting the SEF URLs for that section and let them recreate from scratch.
Other than that, I can only offer you our paid support service, so we could check what exactly is going on on your website: www.artio.net/e-shop/support-services/joomla-related-support-1h
ARTIO Support Team
The topic has been locked.
  • Page:
  • 1
  • 2
User Login Empty