Menu Content

Support

> Forums, FAQs & Paid Support
Welcome, Guest
Username Password: Remember me

Can it work on a site on a subdomain?
(1 viewing) (1) Guest
Support forum for customers who have purchased JoomSEF 4 (Joomla 1.6/1.7/2.5+ compatible). Archive only, no new post can be added.

NOTE: This category has been locked. If you have purchased paid version, please, use our Support Ticket system instead. If you are using free edition, please see the Community Support section.
  • Page:
  • 1

TOPIC: Can it work on a site on a subdomain?

Can it work on a site on a subdomain? 10 years, 10 months ago #40848

Hi there

I'm migrating my site from J 1.5 to 2.5 and am doing so in a sub-domain of the live site. I want to get JoomSEF installed and operating correctly on the development site before taking it live. So far I've not been able to get it working properly: even JoomSEF is creating the ULS I want, they are not resolving to the correct pages - rather resolving as a page not found - that is to say the banner of live site is repeated down the page and clicking any menu item after that takes you to the live site.

My question is: can JoomSEF work on a site that is a sub-domian of another site? ... or do I have to wait until I move the J 2.5 site to the root of the server in taking it live for JoomSEF to work?

Thanks in advance

commscath
Last Edit: 10 years, 10 months ago by commscath.
The topic has been locked.

Re: Can it work on a site on a subdomain? 10 years, 10 months ago #40850

  • dajo
  • OFFLINE
  • Posts: 5069
Hi,
JoomSEF shouldn't have any problem working in a subdomain. The problem could be caused by your .htaccess file, or with a "www/non-www domain handling" option in JoomSEF's configuration. There could also be a root domain hard-coded in your Joomla's configuration file.
ARTIO Support Team
The topic has been locked.

Re: Can it work on a site on a subdomain? 10 years, 10 months ago #40868

Thanks very much for the reply dajo.


It seems it was an issue with a .htaccess file designed to provide a password protection layer that was installed in the J 1.5 site which I was upgrading from.

When I attempted to edit the settings in JoomSEF > Edit .htaccess, I ended up with a 500 Internal server error

I found this article useful to help me with the next step.

I deleted the .htaccess file on the root directory and renamed the htaccess.txt file .htaccess.

Now I'm all good.

Very happy!

Thanks again for your quick response. :)
The topic has been locked.
  • Page:
  • 1
User Login Empty