Menu Content

Support

> Forums, FAQs & Paid Support
Welcome, Guest
Username Password: Remember me

I sometimes get - HTTP 500 Internal Server Error
(1 viewing) (1) Guest
Support forum for users using free edition of JoomSEF 3 (Joomla 1.5 compatible). These forums are mainly for mutual help between users.

Please note that due to our capacity limitations, we do not monitor these forums regularly.

TOPIC: I sometimes get - HTTP 500 Internal Server Error

I sometimes get - HTTP 500 Internal Server Error 11 years, 7 months ago #8846

So i moved my server.
I reinstalled my system (centos), reinstalled apache and everything else.
I tryed to make the same settings, copied the site and the databases and they worked.
I installed the latest version of joomsef, reconfigured it, and it worked.
But i now have a problem that i really dont know where to look to fix it.
I get from time to time the HTTP 500 Internal Server error.
But this only happens once a week maybe, and i saw that if i go and remove all the existing sef urls the site works again.
What could it be ?!
Can someone please help me out.
The topic has been locked.

Re:I sometimes get - HTTP 500 Internal Server Error 11 years, 7 months ago #8868

  • jaku
On what occassion do you get the 500 Internal server error? (accessing what URL)
To the extent of my knowledge of Apache and occurence of 500 Internal server error message, if this is appearing randomly, I would doubt about direct connection to JoomSEF or any PHP code in general.

500 error appears when there is problem in configuration files - usage of unsupported or disallowed directives in .htaccess or vhost configuration and similar. So, unless some script is modyfying Apache configuration files regularily or on random basis, I see no connection between the error occurence and Joomla code.
Last Edit: 11 years, 7 months ago by .
The topic has been locked.

Re:I sometimes get - HTTP 500 Internal Server Error 11 years, 7 months ago #8883

well i cannot acces the whole site.
and like i said, if i remove all the existing urls, i works.
The topic has been locked.

Re:I sometimes get - HTTP 500 Internal Server Error 11 years, 7 months ago #8900

does anyone have any ideea !?
i will probably be forced to not use it :(
The topic has been locked.

Re:I sometimes get - HTTP 500 Internal Server Error 11 years, 7 months ago #8909

  • jaku
The topic has been locked.

Re:I sometimes get - HTTP 500 Internal Server Error 11 years, 7 months ago #8911

yes i saw that link.
the thing is i have commented "Options +FollowSymLinks" and i didnt edit htaccess at all, i left it like the documentation says.
and like i said, this doesnt happen when i modify something (cuz i dont), it just happens on some day (who knows what day) probably because of some new sef link .
im saying this because, like i said in my post, if i delete all the sef urls and clear all the cache, it works.
the server makes the urls (new urls) and the site loads.
so thats why im thinking it has something to do with the urls.
but i dont know how exactly to see from what link i have this problem (if this is the case).
The topic has been locked.
User Login Empty