Menu Content

Support

> Forums, FAQs & Paid Support
Welcome, Guest
Username Password: Remember me

404 error when translating virtuemart component
(1 viewing) (1) Guest
Support forum for customers who have purchased JoomSEF 3 (Joomla 1.5 compatible). Archive only, no new post can be added.

NOTE: This category has been locked. If you have purchased paid version, please, use our Support Ticket system instead. If you are using free edition, please see the Community Support section.
  • Page:
  • 1

TOPIC: 404 error when translating virtuemart component

404 error when translating virtuemart component 15 years, 5 months ago #5472

Hi:

I have downloaded JoomSEF 2.3.0 and Virtuemart extension 1.1.3. My order # is 3343 for the Virtuemart extension download.

Anyway, I got it to work perfectly on my local server and I am having some trouble on the real site.

There are two problems:

Problem #1: Virtuemart component URL

I have a menu link to the virtuemart component.

The non-SEF URL is
www.puxzycat.com/index.php?option=com_vi...=traditional_chinese
The JoomSEF URL is
www.puxzycat.com/component/option,com_vi...traditional_chinese/

or (English version using Joomfish)

The non-SEF URL is
www.puxzycat.com/index.php?option=com_vi...=72&lang=english
The JoomSEF URL is
www.puxzycat.com/component/option,com_vi...mid,72/lang,english/

Well, it doesn't work. Everything else works fine. The funny thing is, it works perfectly on my local server. I just can't figure it out, please help!


Problem #2: Xmap component

I am trying to create a site map for my site. It will list all of the products that I have on the e-shop. But another funny thing happened.

Say for product

www.puxzycat.com/component/page,shop.pro...rt/Itemid,1/lang,tr/

This link works. But on the sitemap, it returned this link...

/component/option,com_virtuemart/page,shop.product_details/flypage,shop.flypage/category_id,90/product_id,659/manufacturer_id,1/Itemid,72/lang,tr/

Note the position of "option,com_virtuemart" is different. The latter link did not work and gives a 404 error.

Again, the funny thing is that it worked perfectly ok when I tested it on a local copy. I think these two problems are related and probably due to something stupid that I missed. But I looked at the JoomSEF settings on both my local and production servers and I cannot find any difference. Please help me!!!

Thanks.

Albert
The topic has been locked.

Re:404 error when translating virtuemart component 15 years, 5 months ago #5476

  • miun
  • OFFLINE
  • A pesimist is just a well-informed realist.
  • Posts: 563
Hello,

first of all, there is one thing you mention that is alarming to me.

You say that JoomSEF URL looks like "www.puxzycat.com/component/option,com_vi...lang,english/", but that is not JoomSEF URL.
JoomSEF should give you URL such as "www.puxzycat.com/en/eshop".

What you have posted appears to be a standard Joomla SEO URL.

Therefore, first of all, make sure the JoomSEF is activated and that setting in Joomla Global Configuration related to SEO are set to "yes" as well. (especially the option use .htaccess file)

There may also be relation with the things not working right, as there may be some setting you forgot to switch to on.

As regards xmap component, we have not yet tested JoomSEF with this one. However Joomap should work fine.
ARTIO Support Team
The topic has been locked.
  • Page:
  • 1
User Login Empty