Menu Content

Podpora

> Diskusní fóra, FAQs & placená podpora
Welcome, Guest
Username Password: Remember me

Wrapper links no longer working
(1 viewing) (1) Guest
Support forum for customers who have purchased JoomSEF 3 (Joomla 1.5 compatible). Archive only, no new post can be added.

NOTE: This category has been locked. If you have purchased paid version, please, use our Support Ticket system instead. If you are using free edition, please see the Community Support section.
  • Page:
  • 1

TOPIC: Wrapper links no longer working

Wrapper links no longer working 8 years, 11 months ago #18998

The wrapper links I have in the menu on a site are no longer working. What happens now is that they do open the correct pages, but NOT as a wrapper. The pages being opened are hosted on the same server, and are normal php files, but now they no longer load within the 'site'
Any suggestions?
thanks
- Francois

UPDATE

It seems that one wrapper link in the menu IS working (for me anyway). The other links that are wrappers are not displaying correctly.

An example of a URL that does not display properly is www.cabs.co.za/car-rental-rates-group-j.htm
An example of a URL that seems to work properly for me still is www.cabs.co.za/car-rental-rates.html

If you view the source of one of the URLs that are not working properly in the wrapper format, I see some code and the following message: "This option will not work correctly. Unfortunately, your browser does not support inline frames."

I have not changed the link information in the menu, so these are links that were working perfectly before, and now do not. I have edited the mod_wrapper extension for JoomSEF, changing handling, but nothing changes no matter which option I choose.

The site is running on JoomSEF 3.7.5 Paid

Database Version: 5.0.51a-24-log
Database Collation: utf8_general_ci
PHP Version: 5.2.13
Web Server: Apache/2.2.11 (Unix) mod_ssl/2.2.11 OpenSSL/0.9.7e mod_auth_pgsql/2.0.3
Web Server to PHP interface: cgi-fcgi
Joomla! Version: Joomla! 1.5.22 Stable
Last Edit: 8 years, 11 months ago by SouthAfricaDude. Reason: more information
The topic has been locked.

Re: Wrapper links no longer working 8 years, 11 months ago #19050

  • dajo
  • OFFLINE
  • Posts: 5070
Hello,

Use the JoomSEF's URLs Manager, find the "car-rental-rates-group-j.htm" SEF URL and post its corresponding Real URL please.
Also please make sure that this is really related to JoomSEF - try disabling JoomSEF in its Configuration and check if this problem happens.

Best regards,
ARTIO Support Team
ARTIO Support Team
The topic has been locked.

Re: Wrapper links no longer working 8 years, 11 months ago #19068

Hi David,

The real URL is: index.php?option=com_wrapper&lang=en&view=wrapper&Itemid=71

If I have JoomSEF enabled, I have the problem, when I disable JoomSEF in its config and try the above URL it works perfectly

- Francois
The topic has been locked.

Re: Wrapper links no longer working 8 years, 11 months ago #19105

  • dajo
  • OFFLINE
  • Posts: 5070
There is probably some error encountered in the PHP code. Try enabling the error reporting on your server or look into the server's error logs to see if there is any PHP fatal error reported, so we can find out what the problem is.

Best regards,
ARTIO Support Team
ARTIO Support Team
The topic has been locked.

Re: Wrapper links no longer working 8 years, 11 months ago #19138

Hi David,

I dont see any errors in the server log. I have turned on error reporting to maximum in the Joomla config, but dont see any errors output onto the page in the front end.

UPDATE

The JoomSEF URL car-rental-rates-group-j.htm is a customised URL. Originally JoomSEF creates a URL called vehicle-group-j.html.

I have tested deleting my custom URL (car-rental-rates-group-j.htm), cleaning the cache, then reloading the page on the front end. The dynamically created URL that JoomSEF creates is again back to 'vehicle-group-j.html'. When I click this URL it works perfectly!

I have now again edited the URL so that it is changed it back to 'car-rental-rates-group-j.htm', and saved it. When I clean the cache, and reload the page in the front end, the problem is back!

Any suggestions?
It seems to be a problem with me customising the URL.
Last Edit: 8 years, 11 months ago by SouthAfricaDude.
The topic has been locked.

Re: Wrapper links no longer working 8 years, 10 months ago #19217

Any other suggestions would be greatly appreciated :)
The topic has been locked.
  • Page:
  • 1
Přihlášení uživatele Prázdný