Menu Content

Support

> Forums, FAQs & Paid Support
Welcome, Guest
Username Password: Remember me

J 3.2 Month Layout Template not loaded
(1 viewing) (1) Guest
Support forum for users using free edition of Book it!. These forums are for mutual help among users.

NOTE: Due to our capacity limitations, ARTIO does not monitor this forum category regularly. If you want direct support from ARTIO, please start a ticket at Support Dashboard. If you have no support ticket available, you need to purchase it. .
  • Page:
  • 1

TOPIC: J 3.2 Month Layout Template not loaded

J 3.2 Month Layout Template not loaded 10 years, 6 months ago #42428

When Clicking "Make reservation" in Skoda the browser goes to the page
/index.php?option=com_booking&Itemid=101&view=subject&id=1:skoda-octavia-combi-2-tdi-1
and no site template is loaded
Page does not consist of any body or header tags just the content of form.
Have looked into code but could not find the reason
Please help

screen_artio.jpg
Last Edit: 10 years, 6 months ago by madmax_b.

Re: J 3.2 Month Layout Template not loaded 10 years, 5 months ago #42547

I have exactly the same issue. I have installed Artio Booking on a new clear Joomla v3.2. It´s the same. It doesn´t work.

Re: J 3.2 Month Layout Template not loaded 10 years, 5 months ago #42558

i have found the problem.
i wonder the so called SUPPORT and developers.
PEOPLE! If You want to sell a thing then make the DEMO working perfectly!
No one would buy anything he can not test.

Joomla 2.5 the same problem because the problem is in code of component but not in anything else.

for component installable ZIP:
com_booking2_free.zip\site\views\subject\tmpl\default_bookitform.php
for installed component:
\components\com_booking\views\subject\tmpl\default_bookitform.php

line 69: <? } ?>
SHOULD look like <?php } ?>
after this problem is fixed.
regular php logger goes crazy making harder to find the problem.

shame...
support, you owe me money for the wasted time, troubleshooting, testing on different joomla versions and support of Your users. another words - doing Your job...

Re: J 3.2 Month Layout Template not loaded 10 years, 5 months ago #42593

  • jitr
  • OFFLINE
  • ARTIO Support
  • Posts: 1432
Hello, in PHP configuration should be short_open_tag = On
ARTIO Support Team

Re: J 3.2 Month Layout Template not loaded 10 years, 5 months ago #42594

  • mitk
Hello,

thank you for your report.
You can also solve the problem with server settings: www.artio.net/faqs/booking/troubleshooti...error-unexpected-end

Re: J 3.2 Month Layout Template not loaded 10 years, 5 months ago #42602

short_open_tag = On

is not a regular php configuration

You can also solve the problem with server settings: www.artio.net/faqs/booking/troubleshooti...error-unexpected-end


if all php tags over the project were opened in short manner than it would be a rule for the project and this rule should be represented in installation instructions: "prease reconfugure your PHP on hosting". Its not always avaliable on different hostings but OK.

but if it is the very only one tag from all over the big project - its a BUG.

All projects should be tested with the most common settings the user can have, higher level of security and minimal options turned ON and very common memory or hardware configuration.
If something should be changed from common server configuration - user should know it from installation instructions but not from digging Your code for couple hours or waiting a week on forum or wasting time for digging troubleshooting.
Last Edit: 10 years, 5 months ago by madmax_b.
  • Page:
  • 1
User Login Empty