Menu Content

Support

> Forums, FAQs & Paid Support
Welcome, Guest
Username Password: Remember me

ZOO item custom title not displaying correctly
(1 viewing) (1) Guest
Support forum for customers who have purchased paid JoomSEF extension. Archive only, no new post can be added.

NOTE: This category has been locked. If you have purchased paid version, please, use our Support Ticket system instead. If you are using free edition, please see the Community Support section.
  • Page:
  • 1
  • 2

TOPIC: ZOO item custom title not displaying correctly

ZOO item custom title not displaying correctly 12 years, 2 months ago #29598

The ZOO extension in his 3.0.6 version does not include the item custom title in the title tag of the generated url. Is this a bug or not given feature?

Thanks
The topic has been locked.

Re: ZOO item custom title not displaying correctly 12 years, 2 months ago #29606

  • dajo
  • OFFLINE
  • Posts: 5069
Hi,
I don't understand the problem. What do you mean by custom title? Do you mean Custom menu title in the Zoo extension parameters on Common tab? Or some title of Zoo item? But Zoo only allows to set the Name, Slug and Subtitle of its items.
ARTIO Support Team
Last Edit: 12 years, 2 months ago by dajo.
The topic has been locked.

Re: ZOO item custom title not displaying correctly 12 years, 2 months ago #29609

Since ZOO 2.5 you can customize the tittle of the display page of the item or category. When creating/editing an item/category, at the right sidebar appears DETAILS, METADATA, TEMPLATE and TAGS. From METADATA section you can edit the TITTLE, DESCRIPTION, KEYWORDS, ROBOTS and AUTHOR meta tags of the generated page for displaying the item/category.

The topic has been locked.

Re: ZOO item custom title not displaying correctly 12 years, 2 months ago #29610

  • dajo
  • OFFLINE
  • Posts: 5069
This is not a bug, you can either set the page title in Zoo or in JoomSEF's meta tags. If the JoomSEF's URL title tag is empty, the default one generated by Joomla (hence by Zoo) is being used.
ARTIO Support Team
The topic has been locked.

Re: ZOO item custom title not displaying correctly 12 years, 2 months ago #29638

No, in a custom title of Joomla default content works perfectly but if I put a custom title for a ZOO item this custom title it's not included in the <title> tag.

EX. ZOO

Iten name = World War Z
Custom tittle (see image in post 3) = BOOK World War Z

If JoomSEF is disabled the <title> tag is "BOOK World War Z"
If JoomSEF is enabled the <title> tag is "World War Z"


EX. JOOMLA CONTENT

Article name = Buy a Book
Custom tittle (see image in post 3) = How to: buy a book

If JoomSEF is disabled the <title> tag is "How to: buy a book"
If JoomSEF is enabled the <title> tag is "How to: buy a book"


If you see, this means that CUSTOM TITLE in ZOO isn't handled properly by JoomSEF ZOO extension.
Last Edit: 12 years, 2 months ago by abellan.
The topic has been locked.

Re: ZOO item custom title not displaying correctly 12 years, 2 months ago #29649

  • dajo
  • OFFLINE
  • Posts: 5069
Aah, now I understand. I've checked it and the problem is that our Zoo extension always generates its own title according to its parameters set in JoomSEF. We'll add an option to disable this title generation in next Zoo extension version.
In the meantime, you can disable usage of JoomSEF titles in JoomSEF's Configuration on the Title and Meta Tags tab - just set the "Prefer JoomSEF titles" to "No". Or you can manually remove only the titles you don't want to use on the Manage Meta Tags page in JoomSEF.
ARTIO Support Team
The topic has been locked.
  • Page:
  • 1
  • 2
User Login Empty