Menu Content

Support

> Forums, FAQs & Paid Support
Welcome, Guest
Username Password: Remember me

Critical Bug Report
(1 viewing) (1) Guest
Support forum for customers who have purchased JoomSEF 3 (Joomla 1.5 compatible). Archive only, no new post can be added.

NOTE: This category has been locked. If you have purchased paid version, please, use our Support Ticket system instead. If you are using free edition, please see the Community Support section.

TOPIC: Critical Bug Report

Re:Critical Bug Report 10 years, 9 months ago #7979

  • y2ksw
  • OFFLINE
  • Joomla: latest; JoomSEF: latest
  • Posts: 20
The file cache seems to work, no crashes to report.
The topic has been locked.

Re:Critical Bug Report 10 years, 9 months ago #7987

  • jaku
  • OFFLINE
  • Posts: 2697
Hi,

thanks for your posts
.
We had problems with eAccellerator with other PHP applications as well, not just JoomSEF. It seems to contain some bugs causing Apache crash. This means it is most likely not problem of PHP or its code, but eAccellerator self. So I am glad it works for you now.

If you will have problems again we have quite positive experience with replacing eAccellerator with PHP APC (from Pear repository - www.php.net/apc).
ARTIO Support Team
The topic has been locked.

Re:Critical Bug Report 10 years, 9 months ago #8246

  • y2ksw
  • OFFLINE
  • Joomla: latest; JoomSEF: latest
  • Posts: 20
We still have this problem also with cache on file, but much less. Can you please schedule to check that particular object if it isn't NULL or contains NULL entries?

Thanks.
The topic has been locked.

Re:Critical Bug Report 10 years, 9 months ago #8323

  • jaku
  • OFFLINE
  • Posts: 2697
Hello,

I am sorry to day that, but we are not going to make special patches because of eAccelerator bugs.
As I wrote above, we are also trying eAccellerator earlier, but we found it buggy and problematic, so we decided not to use it anymore.
I would advice you to switch to more reliable PHP acceleration solution, or you will have to make the needed patches on your own. (however, I am not sure they will help anyway)
ARTIO Support Team
The topic has been locked.

Re:Critical Bug Report 10 years, 9 months ago #8338

  • y2ksw
  • OFFLINE
  • Joomla: latest; JoomSEF: latest
  • Posts: 20
Sorry, but you missed I was using file caching and the problem still persists.

Right now I'm forced to use no cache in order to get reliably JoomSEF running.

I understand you will not make special patches, but if the problem is in your code (and it is denoted as that from PHP error handling), I will complain to you whenever one appears.

Most probably you have somewhere an uninitialized string which however is required.

If eAccelerator or even file caching would really be buggy, a wild roar would shake the web and really nobody would not have heared it. All I was asking is to check once again that specific object in order to be 200% sure it isn't your code causing a problem.

I am a coder myself and know it is terribly easy to miss the point. And specificly when I know about a problem and also other people tell me about and try to help me to trace it down, I do my best efford to get it fixed. Because that is what makes the difference.
The topic has been locked.

Re:Critical Bug Report 10 years, 4 months ago #10579

  • y2ksw
  • OFFLINE
  • Joomla: latest; JoomSEF: latest
  • Posts: 20
[Thu Feb 18 16:40:44 2010] [error] [client 79.27.105.179] PHP Warning: Unexpected character in input: ''' (ASCII=39) state=1 in /vhosts/*.com/httpdocs/cache/joomsef.cache on line 1730, referer: forum.*.com/showthread.php?t=49888
[Thu Feb 18 16:40:44 2010] [error] [client 79.27.105.179] PHP Parse error: syntax error, unexpected $end, expecting ']' in /vhosts/*.com/httpdocs/cache/joomsef.cache on line 1730, referer: forum.*.com/showthread.php?t=49888

Maybe this report will help you to find the problem, which is related to missing or erratic escaping of some characters.

Of course, the latest version is installed.
The topic has been locked.
User Login Empty