Menu Content

Support

> Forums, FAQs & Paid Support
Welcome, Guest
Username Password: Remember me

Several problems
(1 viewing) (1) Guest
Support forum for customers who have purchased this product. Archive only, no new post can be added.

NOTE: This category has been locked. If you have purchased paid version, please, use our Support Ticket system instead. If you are using free edition, please see the Community Support section.
  • Page:
  • 1

TOPIC: Several problems

Several problems 6 years, 9 months ago #43704

Hello,

I have several problems with pdf invoice.
1) The currency symbol is € (default is store) on invoice but I have prices only in $ for some users, the symbol should be $ for prices in $.
2) Tax rate on pdf invoice is -100% but I don`t have in that case tax rate set at all.
3) After adding a coupon code some strange prices shows up in items list as you see in attached file. The final price is ok but as I say should be in $.

I attached 2 files, one without and one with coupon code.
The files cannot be attached so i have uploaded on server:
www.awards-wholesale.com/invoice_14-0001...hout-coupon-code.pdf
www.awards-wholesale.com/invoice_14-0002...with-coupon-code.pdf

Best regards!
The topic has been locked.

Re: Several problems 6 years, 9 months ago #43759

  • pama
  • OFFLINE
  • Posts: 489
Hello. Thanks for your notes.

1) Currently, VM saves all prices in order in default store currency. It is not possible to have more prices in one order. However, VM supports payment in different currency than store's. In that case, we added option to last version to Page Appearance -> Display in payment currency. This will convert prices (and of course symbols) to currency that was used for payment method. Because VM stores fixed exchange rate for it in moment of order, we can do it safely. But Iam not sure if this is what you asked about? We only display currency that VM stored order in. How your prices are set-up?

2) Sorry, that is partly error in our code. There should be 0%. We will fix that in next release.

3) These strikethrough prices are displayed when there is some override price applied. It's same way how VM displays the order. You can turn them off in Invoice Items Configuration -> Show Prices Before Discount (on right side).

If there is some error, it depends also how order was created - was it created by VM front-end or by VM Invoice back-end? In both cases, it should generate same results; if not, that is error on our side.

Also, please, provide your VirtueMart and VM Invoice version, also make sure you have newest version of both. Thanks much.
ARTIO Support Team
The topic has been locked.

Re: Several problems 6 years, 9 months ago #43770

Hello,
thanks for your reply.

1) we have flat prices for each currency, so the convertECB is swithed off. I`m looking for sollution to be saved the currency simbol in actual purchase currency.
2) when will be the next release?
3) solved by turning off the above mentioned.

I have the latest verison of both:
ARTIO VM Invoices
Version: 2.0.33
Virtuemart
2.0.26d

Best regards!
The topic has been locked.

Re: Several problems 6 years, 9 months ago #43775

  • pama
  • OFFLINE
  • Posts: 489
Hello.

1) That must be done with some hack to VM code. Because currently, "VM - Currencies Selector" module only affect display prices, but order is still saved in default VM currency. It can be hacked by that way it saves currencly selected currency in that module to column "order_currency" (But it will only changes "symbol", not convert prices using currency rate. ) or "user_currency_id" (<= there is saved payment currency now + rate to "user_currency_rate" - it can work if you then select "Display in payment currency"). There are some options :).

Or you can change currecny afterwards by opening order in VM invoice and changing currency there.

2) I think today or tommorow.
ARTIO Support Team
Last Edit: 6 years, 9 months ago by pama.
The topic has been locked.

Re: Several problems 6 years, 9 months ago #43794

Hello,

thanks for the reply nd for the help.
1) I will try that, I`m beginer in php but motivated to learn :)
2) ok, thanks.

Best regards!
The topic has been locked.
  • Page:
  • 1
User Login Empty