Menu Content

Support

> Forums, FAQs & Paid Support
Welcome, Guest
Username Password: Remember me

Bug reports and first impressions
(1 viewing) (1) Guest
Support forum for users using free edition of JoomDOC. These forums are mainly for mutual help between users.

NOTE: Due to our capacity limitations, ARTIO does not monitor this forum category regularly. If you want direct support from ARTIO, please start a ticket at Support Dashboard. If you have no support ticket available, you need to purchase it.
  • Page:
  • 1

TOPIC: Bug reports and first impressions

Bug reports and first impressions 5 years, 1 month ago #46868

Hi.

I am evaluating JoomDoc for possible use on our site. It seems like a capable piece of software, but I do have a couple of bugs to report:

1. I navigated to the document management page in admin before I went to the config page. I was given a message stating that a folder named "documents" had been created. It seems like it takes that as a default path if the path hasn't been defined in config. This is good. However, I then went to config, and found that the path field was mandatory -- it forced me to enter a path, even though it had already decided to use the default. This is inconsistent behaviour; it should have populated that config value when it decided on the default, or the config field should not be mandatory and blank would allow it to use the default.

2. When I entered the path, at first I didn't realise it needed to be a full absolute path, so I just entered "documents". This was accepted by the config program, but when I returned to the document management page, it crashed. No useful crash message; even PHP's error log just says it timed out after 30 seconds. I fixed this by correcting the path in config to be the full absolute path, but the crash is a nasty error and needs to be fixed.

That's all for now. I'll report back if I find anything else.

Thank you.


Simon C.
  • Page:
  • 1
User Login Empty