Menu Content

Support

> Forums, FAQs & Paid Support
Welcome, Guest
Username Password: Remember me

VM products issue and a module disappearing?!
(1 viewing) (1) Guest
Support forum for users using free edition of JoomSEF 3 (Joomla 1.5 compatible). These forums are mainly for mutual help between users.

Please note that due to our capacity limitations, we do not monitor these forums regularly.
  • Page:
  • 1

TOPIC: VM products issue and a module disappearing?!

VM products issue and a module disappearing?! 7 years, 7 months ago #33941

Hi,

I'm working one some minor web tweaks for a client. One of the things they want is for additional products within the same category to display below a product. Which is fine, I wrote the code for it and it works. But the issue I'm having is that with SEF enabled (JoomSEF installed obviously) some of the products are displaying but think they're in a different category than they are.

For example, this is a sub-sub-category here: www.walnutmelbourne.com.au/virtuemart/ch...-flats/alexis-python

And this is one product that is working fine in the above sub-sub-category: www.walnutmelbourne.com.au/virtuemart/al...python-ballet-purple (note the left side menu shows it being in the sub-sub-category "alexis python").

This one however is not working: www.walnutmelbourne.com.au/virtuemart/al...on-ballet-chilli-red (now note that the left menu is showing it to be in the sub-category (one level up)).

This wouldn't really matter except that the script I've written takes all products from the same category level that the viewed product is in, then displays them below the product (currently I just have 'recently viewed' there to fill the space). Because of this, the chilli red shoe does not show additional items. Which would also be okay except that some other shoes are showing as being in a different sub-sub-category and therefore listing other products below from the wrong category, which can confuse costumers but also looks unprofessional.

So thats issue 1.

Issue 2 is that for some reason the left side product menu has disappeared on one page. It reappears with SEF disabled. This is the page: www.walnutmelbourne.com.au/stockists/stockist

The reason why this is bad is simply for that the layout looks ugly without the left side menu there.

If anyone can help it would be greatly appreciated!

Lee

Re: VM products issue and a module disappearing?! 7 years, 7 months ago #33949

Fortunately I was able to solve the issue myself. I'll post my findings here for anyone else having the same issue.

The problem was indeed with JoomSEF and when taking a look at the ‘SEF’ URL’s it created, I noticed there were 4-5 different URL’s pointing at the same ‘SEF’ URL for many products. This was more than likely the clients fault for not using JoomSEF properly.

For example, this link here… www.walnutmelbourne.com.au/virtuemart/lo...-leather-ballet-bone

… was pointing to:

- index.php?option=com_virtuemart&category_id=157&flypage=flypage.tpl&manufacturer_id=1&page=shop.product_details&product_id=5403
- index.php?option=com_virtuemart&category_id=42&flypage=flypage.tpl&manufacturer_id=1&page=shop.product_details&product_id=5403&Itemid=100046
- index.php?option=com_virtuemart&category_id=111&flypage=flypage.tpl&manufacturer_id=1&page=shop.product_details&product_id=5403&Itemid=100046

So I took the liberty of going through every single published children’s and ladies product in the store, finding the broken ones and fixing them. I was then able to go ahead and add the ‘other colours’ (additional products in same category) code back in and it is now working perfectly!

Also, the stockists page issue was resolved in a similar way. It only had one SEF URL so I just deleted it and rebuilt it. It’s now working perfectly too.
  • Page:
  • 1
User Login Empty