Menu Content

Support

> Forums, FAQs & Paid Support
Welcome, Guest
Username Password: Remember me

Screen goes blank in admin viewmode=3
(1 viewing) (1) Guest
Support forum for users using free edition of JoomSEF 4 (Joomla 1.6/1.7/2.5+ compatible). These forums are mainly for mutual help between users.

Please note that due to our capacity limitations, we do not monitor these forums regularly.
  • Page:
  • 1
  • 2

TOPIC: Screen goes blank in admin viewmode=3

Screen goes blank in admin viewmode=3 12 years, 5 months ago #27582

Hi,

I have been zipping along adding our SEFs (thousands of them) when suddenly the admin page for administrator/index.php?option=com_sef&controller=sefurls&viewmode=3 went blank.

I checked the database and saw this happened when I tried to add link number 4100 (4099 were listed).

We have used JoomSEF before with our old 1.5 installation and never had this issue. Is there some sort of limit on the list length now?

If I sort it by "custom" or "sef" I can show all still, but if I try to list all while showing all redirects the page goes blank. also, if I make the list length 50 or 100 the "Show All Redirects" link works but when I try to click next or another page number it goes blank again.

We are using Joomla 1.7.2 with newest JoomSEF 4.2.3 I had some trouble trying to post at first but we did purchase both the extension and the virtuemart plugin for it.

Re: Screen goes blank in admin viewmode=3 12 years, 5 months ago #27608

  • dajo
  • OFFLINE
  • Posts: 5069
How long does it take to load the page? Maybe the execution time limit is exceeded. Anyway the blank page means some error in PHP engine was encountered. Please enable the error_reporting and display_errors on your server or check the error log files to see what the error is.
ARTIO Support Team

Re: Screen goes blank in admin viewmode=3 12 years, 5 months ago #27623

no, the screen instantly goes blank. also, as I said it ONLY happenes in viewmode=3 "listall", if I leave it at 50 it works, if I filter to custom or sef it will "list all" which is about 800+ for each of those. but it is the full list all that it breaks and as I said the records were sitting at 4099 when it happened which makes me suspicious there is a hard/coded limit somewhere. I have checked my server error logs and have not seen anything but I will enable debug, though I'm not convinced that will show anything either.

Re: Screen goes blank in admin viewmode=3 12 years, 5 months ago #27624

  • dajo
  • OFFLINE
  • Posts: 5069
Nope, there's no hard coded limit in JoomSEF on number of URLs shown. But maybe it reaches the allowed memory limit for PHP scripts on your server.
ARTIO Support Team

Re: Screen goes blank in admin viewmode=3 12 years, 5 months ago #27625

I turned on joomla system debug and tried to change the "all sefs" to show "all" and completely blank screen. source shows nothing, no header, body, nothing.
=(

Re: Screen goes blank in admin viewmode=3 12 years, 5 months ago #27630

ok, well I figured out where the problem lay and "fixed" it - kind of.

the problem is with ob_get_clean here:
libraries/joomla/environment/response.php ~line 198

if I comment that out it works fine. something to do with output buffer size. I know that this is more a core joomla thing but it is only happening with the SEF list.

I wish I could fix it without removing that so if anyone has any ideas I'd appreciate the help.
  • Page:
  • 1
  • 2
User Login Empty