Menu Content

Support

> Forums, FAQs & Paid Support
Welcome, Guest
Username Password: Remember me

Jomsocial Plugin -> delete group posts not working
(1 viewing) (1) Guest
Support forum for customers who have purchased paid JoomSEF extension. Archive only, no new post can be added.

NOTE: This category has been locked. If you have purchased paid version, please, use our Support Ticket system instead. If you are using free edition, please see the Community Support section.
  • Page:
  • 1

TOPIC: Jomsocial Plugin -> delete group posts not working

Jomsocial Plugin -> delete group posts not working 10 years, 6 months ago #41245

Hello Support Team

our system:

Joomla: 3.1.5
JomSocial: 3.0.4
JomSEF: 4.4.4
JomSEF JomSocial Extension: 3.1.17

We want to setup our community SEF but got a really big problem, which costed us several days and draw back our release date.

If we try to view a group, we got the error message, that the groupid is wrong. JoomSEF don't seem to handle group URLs correctly, causes the site navigates back to view all groups.

So we defined a "Custom non-SEF variable" = "groupid" in the advanced JomSEF configuration.
The result is: groups/general/testgruppe?groupid=1

With this setting we can view the group activities, the members and everything else.
We can share messages and pictures, but we can't delete anything from the activity stream within the group. If we try to delete things, we got the error message "group not found".

We determine the problem as the delete button only open a href #deletepost without anything else on information in the SEF URL.

The non SEF url is: index.php?option=com_community&view=groups&task=viewgroup&groupid=1&Itemid=1253#deletePost

So... how can we fix this, i think its a bug.

Help would be really appreciated. Otherwise, the extension would be a bad choice for us.
The topic has been locked.

Re: Jomsocial Plugin -> delete group posts not working 10 years, 6 months ago #41246

I assume, that you cannot add more than one custom non-sef variable. if you enter groupid; itemid he ignores the second one.
The topic has been locked.

Re: Jomsocial Plugin -> delete group posts not working 10 years, 5 months ago #41375

  • dajo
  • OFFLINE
  • Posts: 5069
Hi,

I'm sorry for the late reply. The problem with #deletePost may be connected to base href setting. Try setting the "Set page base href value" option in JoomSEF's Configuration on the Advanced tab to "Yes - always use full SEO URL".

You can define multiple custom non-SEF variables, just make sure that there's no space between them, for example:
groupid;itemid

Also thank you for your report, we'll fix the problem with groups in next version of our JomSocial extension.
ARTIO Support Team
Last Edit: 10 years, 5 months ago by dajo.
The topic has been locked.
  • Page:
  • 1
User Login Empty