Menu Content

Support

> Forums, FAQs & Paid Support
Welcome, Guest
Username Password: Remember me

K2 RSS feeds stopped working w/ Artio K2 SEF Ext.
(1 viewing) (1) Guest
Support forum for customers who have purchased paid JoomSEF extension. Archive only, no new post can be added.

NOTE: This category has been locked. If you have purchased paid version, please, use our Support Ticket system instead. If you are using free edition, please see the Community Support section.
  • Page:
  • 1

TOPIC: K2 RSS feeds stopped working w/ Artio K2 SEF Ext.

K2 RSS feeds stopped working w/ Artio K2 SEF Ext. 11 years, 2 months ago #37918

Hi all. I have Joomla 2.5.9, ArtioSEF 4.4.0, and Artio K2 Extension 3.0.13.

Everything is working perfectly except for my K2 RSS feeds. However I've already read every post on the topic in this forum and even after three hours of non-stop trial and error, nothing has solved my issue. I have already:
1) Confirmed that Configuration > Advanced > Fix document format is set to 'Yes'
2) Confirmed that all Global Meta Tags Configuration fields are blank.
*****Both were mentioned to be a K2 RSS fix in this thread from a cpl wks ago: www.artio.net/support-forums/joomsef/cus...g-with-artisef#37460
3) Tried manually creating the SEF URL but that loads the feed with no text formatting.
4) Even the default theholidaze.com/feed/rss URL generated by ArtioSEF loads with no text formatting.
*****Screenshot below applies to items #3 and #4
5) And yes, I have also reset my SEF URLs and cleared my cache dozens of times throughout this whole process, just to ensure that was not a factor.



The URLs that used to work before installing this plugin were structured as such: theholidaze.com/component/k2/itemlist?fo...ed&moduleID=256. I had a half dozen RSS feeds all pointing to different module IDs yet now all of them show up as unformatted text.

Anyone have any suggestions or advice for what I have overlooked? I cannot find any settings in the K2 Extension that appear to address the RSS feeds yet know I have to be missing something...
The topic has been locked.

Re: K2 RSS feeds stopped working w/ Artio K2 SEF Ext. 11 years, 2 months ago #37928

  • dajo
  • OFFLINE
  • Posts: 5069
Hi,

I've checked the source code of your RSS and it seems that the problem is caused by an extra newline character on the beginning:
 
<?xml version="1.0" encoding="utf-8"?>

If this happens only with JoomSEF enabled, there's probably some file in JoomSEF left with extra newline character on the end. Thank you for your report, we'll check these and fix them in next version.
ARTIO Support Team
The topic has been locked.
  • Page:
  • 1
User Login Empty