Menu Content

Support

> Forums, FAQs & Paid Support
Welcome, Guest
Username Password: Remember me

Broken menu links
(1 viewing) (1) Guest
Support forum for users using free edition of JoomSEF 3 (Joomla 1.5 compatible). These forums are mainly for mutual help between users.

Please note that due to our capacity limitations, we do not monitor these forums regularly.
  • Page:
  • 1

TOPIC: Broken menu links

Broken menu links 9 years, 3 months ago #23170

  • pantau
Hi, just recently my website started to act a bit funny. I have a standard joomla menu on the left handsite and everything worked just well for the last few years.

Recently I noticed that the menu link will change for all menu items to something like this
http://www.xxx.com/index.php/component/comprofiler/userprofile/latest/tvoje-detaily/pravidla-pro-diskutujici
which of course results in 404. (pravidla-pro-diskutujici is the real link)

I tried to disable ARTIO and SEF in Joomla, deleted the cache, purged all SEF urls and enabled everything again. Worked fine for a hour or so and started again. When I disable ARTIO, everything works well.

What could be causing this and I how can I prevent it from happening? Perhpas comprofiler could be causing this?

Note: I am using the latest vesrsion of ARTIO.
Last Edit: 9 years, 3 months ago by . Reason: code added

Re: Broken menu links 8 years, 11 months ago #25172

Hi Pantau,

Did you find a solution to this>? I'm also having the same problem.

I don't see them on the website - but Google has picked up on them

Many thanks
Claire

Re: Broken menu links 8 years, 11 months ago #25194

  • dajo
  • OFFLINE
  • Posts: 5070
Hi Claire,

We haven't found the exact cause of this problem yet, but it has something to do with Joomla cache, so try disabling it. Also make sure you use the latest version of Joomla.
Try using the Google Webmaster Tools to see how their crawler sees the website. If there are no such URLs, it will probably be fixed after Google reindexes your website.
ARTIO Support Team

Re: Broken menu links 8 years, 11 months ago #25195

  • pantau
Hi, yes I found a solution

joomlacode.org/gf/project/joomla/tracker...racker_item_id=18688

Configuration.php needs to be updated with the following


From this:
var $live_site = '';

To this:
var $live_site = 'www.yourwebsite.com';"

Re: Broken menu links 8 years, 11 months ago #25227

That's great - thanks for getting back to me so quickly.

Claire
  • Page:
  • 1
User Login Empty