Menu Content

Support

> Forums, FAQs & Paid Support
Welcome, Guest
Username Password: Remember me

VirtueMart 1.1.2 breadcrumbs problem
(1 viewing) (1) Guest
Support forum for users using free edition of JoomSEF 3 (Joomla 1.5 compatible). These forums are mainly for mutual help between users.

Please note that due to our capacity limitations, we do not monitor these forums regularly.
  • Page:
  • 1

TOPIC: VirtueMart 1.1.2 breadcrumbs problem

VirtueMart 1.1.2 breadcrumbs problem 11 years, 10 months ago #4860

  • dajo
  • OFFLINE
  • Posts: 5070
Hello,

If you are experiencing problems with SEF URLs in breadcrumbs navigation in VM 1.1.2, please note that this is caused by VM itself. However, it is very easy to fix:
In file /administrator/components/com_virtuemart/classes/mainframe.class.php find the line 363 and change it from:
$cmsPathway->addItem( $item->name, str_replace('&', '&', basename($item->link)) );
to
$cmsPathway->addItem( $item->name, str_replace('&', '&', $item->link) );

If you don't want to change the code, you can download the patched file here:

Attachment mainframe.zip not found


Please note that the file works only for VM version 1.1.2!

Best regards,
ARTIO Support Team
Attachments:
ARTIO Support Team
Last Edit: 11 years, 10 months ago by dajo.
The topic has been locked.

Re: VirtueMart 1.1.2 breadcrumbs problem 1 year, 3 months ago #51672

what you have to do is update the current version because that version is already not used
The topic has been locked.
  • Page:
  • 1
User Login Empty