Menu Content

Support

> Forums, FAQs & Paid Support
Welcome, Guest
Username Password: Remember me

Article and Menu not display correctly
(1 viewing) (1) Guest
Support forum for customers who have purchased this product with priority support pack. Archive only, no new post can be added.

NOTE: This category has been locked. If you have purchased paid version, please, use our Support Ticket system instead. If you are using free edition, please see the Community Support section.
  • Page:
  • 1

TOPIC: Article and Menu not display correctly

Article and Menu not display correctly 6 years, 6 months ago #39464

I have had endless difficulty with JoomSEF not showing the correct content on my site. I have a Menu link which is for an Article in a Blog layout. The menu is a sub menu and is setup in the module manager that the sub menu is displayed then any of the sub menu items are displayed. The Blog is also configured as one long list.

If JoomSEF is switch off it all works correctly but with JoomSEF switch on the Blog Article has deflated back and is not in the long list also the sub menu will not display.

I have Cleared the Cache, Purge SEF URL’s and update URL’s but it’s just the same.
Can anyone please tell me how I can fix this please.


Regards
John
Joomla 3 with JoomSEF 4.4.1
The topic has been locked.

Re: Article and Menu not display correctly 6 years, 6 months ago #39656

  • dajo
  • OFFLINE
  • Posts: 5070
Hi,

I'm sorry for the late reply.
The problem is most likely caused by wrong Itemid being stored with the URL in JoomSEF's database. This can happen for various reasons.
Find the SEF URL in JoomSEF's URLs Manager and check if there are any duplicates. If there are, set the correct one as Active. Check if it contains the correct Itemid - it should be the same as the menu item's ID in Joomla's Menu Manager. If the Itemid is different, edit the URL and change it manually.
ARTIO Support Team
The topic has been locked.
  • Page:
  • 1
User Login Empty