Menu Content

Support

> Forums, FAQs & Paid Support
Welcome, Guest
Username Password: Remember me

not refreshing cache on product save
(1 viewing) (1) Guest
Support forum for users using free edition of M-Turbo. These forums are for mutual help among users.

NOTE: Due to our capacity limitations, ARTIO does not monitor this forum category regularly. If you want direct support from ARTIO, please start a ticket at Support Dashboard. If you have no support ticket available, you need to purchase it.

TOPIC: not refreshing cache on product save

Re: not refreshing cache on product save 7 years, 5 months ago #35203

As far as I can tell the cron job is set up and running properly. I used this handy script to see the status of all cron jobs and according to that script the job mturbo_adminflush is being scheduled regularly and is executing and finishing too ... however when I look into the database core_config_data WHERE path LIKE 'mturbo/event/queue' still has data in it right away after the flush with no other job scheduled ( i wont post it here because it seems to crash the forum page, sorry ) but it's a long series of data, not just '0!'.
Can you suggest why the data is not being flushed even though the cron seems to be working properly.

Re: not refreshing cache on product save 7 years, 5 months ago #35216

  • jich
  • OFFLINE
  • Posts: 254
Hello byronyasgur,

There is insurance preventing taking a long time for flush. The flush is broken if downloading pages take too long time. So queue is not always emptied. However the number of requested pages should be decreased.

There can be problem with synchronization, which is sometime required. If synchronization takes too long time then there will be not enough time for downloading pages.

For a cronjob event there is limit 90 seconds.

We are preparing new way to refresh the updated pages, because the current method is not enough good. Unfortunately just I'm not able to say when it will be done.
ARTIO Support Team

Re: not refreshing cache on product save 7 years, 5 months ago #35229

Sounds like you are saying it's a problem with m-turbo... is that right? Is there anything I can do in the meantime to fix this or workaround it. At the moment all my client can do is either refresh all affected categories manually, which is extremely time consuming and it's easy to miss some ... or refresh all 6000 page views. So this is not a viable solution as it stands.

Re: not refreshing cache on product save 7 years, 5 months ago #35277

  • jich
  • OFFLINE
  • Posts: 254
No. It is not a problem. There is distributed shell script (app/code/local/Artio/Mturbo/Model/scripts/getstatichtml.sh) for downloading pages with M-Turbo package. You can download pages by this script. Default is executed one per day for all pages (default url list), but you can prepare own "url list" and execute it as often as you need by your system cron. It's easy.
ARTIO Support Team

Re: not refreshing cache on product save 7 years, 5 months ago #35279

I don't see how that's a solution.

What I need is something to refresh only affected pages and categories; and only when a change is made, like m-turbo is supposed to work, not every page on the site

"Enable automatic refresh for preview of categories of saved product:". It is similary to previous case. If administrator updates product which is placed in categories "A", "B", "C" ... etc. then M-Turbo refreshes the pages for categories "A", "B", "C" ...etc. . Thus, it refreshes the pages of all categories where updated product is placed.

"Enable automatic refresh for previews of parents of categories of saved product:" M-Turbo refreshes the pages of all parent categories of categories where updated product is placed. Thus, in the context of previous case they are parent of "A", parent of "B", parent of "C" ... etc.
Last Edit: 7 years, 5 months ago by byronyasgur.

Re: not refreshing cache on product save 7 years, 4 months ago #35416

  • jich
  • OFFLINE
  • Posts: 254
Ok, I understand you. In this case we have to investigate why the standard flushing doesn't work on your site.

Try to unzip and load the file in attachment into directory 'app/code/local/Artio/MTurbo/Model/Mturbo' and replace the origin file 'Event.php'. There are added some log outputs. Enable log and try to save some product or category and wait on event mturbo_adminflush, after executing the event write here outputs from var/log/system.log, please (MTurbo's logs will be begining by word "MTurbo").


File Attachment:

File Name: Event.php.zip
File Size: 3 KB
ARTIO Support Team
User Login Empty