Menu Content

Support

> Forums, FAQs & Paid Support
Welcome, Guest
Username Password: Remember me

FaLang + ARTIO: Multilanguage problem
(1 viewing) (1) Guest
Support forum for users using free edition of JoomSEF 4 (Joomla 1.6/1.7/2.5+ compatible). These forums are mainly for mutual help between users.

Please note that due to our capacity limitations, we do not monitor these forums regularly.

TOPIC: FaLang + ARTIO: Multilanguage problem

Re: FaLang + ARTIO: Multilanguage problem 7 years, 5 months ago #30986

  • dajo
  • OFFLINE
  • Posts: 5070
Hi,
There's currently no ETA for this feature.
ARTIO Support Team

Re: FaLang + ARTIO: Multilanguage problem 7 years, 3 months ago #32094

Hi!

I'm using J! 2.5.6, FaLang 1.1.6 and JoomSEF 4.2.8 and I have a little problem. I have two languages on my website and I want to remove the language code for the default one.
My default language is Romanian and the other one is English. So, when I enter my website the home page displays /ro and I want to remove that... All my settings in artio are the default ones, except Language tab where I've disabled "Get language from browser setting?" and "Save language to cookie?"

Another problem I have is with Phoca Guestbook's captcha. When I'm on default language it's ok, but when I'm on EN the captcha image doesn't displays (the link from src is not generated corectly).

PS: my website is at this moment on localhost
PS2: i've downloaded the phocaguestbook extention for joomsef.

Thanks!

Re: FaLang + ARTIO: Multilanguage problem 7 years, 3 months ago #32104

  • dajo
  • OFFLINE
  • Posts: 5070
Hi,

You can disable the "Always use language" option to remove langauge code for default language from SEF URLs, but currently there's no way to remove language code from homepage URLs. An option for this will be available in next version of JoomSEF.

For captcha image problem, try changing the "Set page base href value" option in JoomSEF's Configuration on the Advanced tab to "No - disable base generation".
ARTIO Support Team

Re: FaLang + ARTIO: Multilanguage problem 7 years, 3 months ago #32122

I've tested many times the options from Language tab and I can confirm that the removal of default language code is not possible.
I tried what you told me to do about Phoca Guestbook and it's not working, the captcha image for EN doesn't shows. Beside this, I found another problem with phocaguestbook: the generated url is not a SEF one, though I have the extension for this component and it looks like this: localhost/decorative/?Itemid=111&option=com_phocaguestbook&view=guestbook&id=1&lang=en.

Thanks in advance!

Re: FaLang + ARTIO: Multilanguage problem 7 years, 3 months ago #32128

I'm back with good news!

Since I moved my website online the guestbook url is a SEF one and I've solved the captcha display problem on EN language by setting the "Relative path" to "Relative patch (no language prefix)" directly from PhocaGuestbook settings.
But there's a problem with phocaguestbook extensions for joomsef. My website host has display errors turned on so that I could see this error which looks like this:
Warning: array_merge() [function.array-merge]: Argument #2 is not an array in /home/decora11/public_html/components/com_sef/sef_ext/com_phocaguestbook.php on line 113

The 113 line is the following:
$title=array_merge($title,$this->_processPagination($uri));

I've commented it and now the error is gone. But it's ok commenting this line?

Re: FaLang + ARTIO: Multilanguage problem 7 years, 3 months ago #32149

  • dajo
  • OFFLINE
  • Posts: 5070
Thank you for your report, we'll check the extension and release a new version when it's fixed.

With the line commented out the pagination URLs will probably not work.
ARTIO Support Team
User Login Empty