Menu Content

Support

> Forums, FAQs & Paid Support

TOPIC: Version 4.3.0 - Fatal error: Maximum execution..

Version 4.3.0 - Fatal error: Maximum execution.. 13 years, 8 months ago #35601

  • Kr3ck3n
  • OFFLINE
  • Posts: 25
Hi,

I've just updated my JoomSEF Free from 4.2.9 to 4.3.0 and I get the following error:
Fatal error: Maximum execution time of 30 seconds exceeded in /home/decora11/public_html/components/com_sef/sef.router.php on line 190

I'm running J! 2.5.8, PHP 5.2.17.. I've also updated the phoca_gallery extension at the same time.

For the moment I'll restore a backup with version 4.2.9, but I hope this will be fixed in the next update.
Thanks!
The topic has been locked.

Re: Version 4.3.0 - Fatal error: Maximum execution.. 13 years, 8 months ago #35604

  • Kr3ck3n
  • OFFLINE
  • Posts: 25
After restoring the backup I updated the phoca_gallery extension and everything is working fine. So the problem is in the new version of Artio JoomSEF.
The topic has been locked.

Re: Version 4.3.0 - Fatal error: Maximum execution.. 13 years, 8 months ago #35613

  • dajo
  • OFFLINE
  • Posts: 5064
Hi,

The "maximum execution time exceeded" error could be caused by many things and the line reported doesn't necessarily cause it. How long does your website normally take to load with JoomSEF 4.2.9?
ARTIO Support Team
The topic has been locked.

Re: Version 4.3.0 - Fatal error: Maximum execution.. 13 years, 8 months ago #35635

  • Kr3ck3n
  • OFFLINE
  • Posts: 25
This is the website, now running JoomSEF 4.2.9.
Normally it takes 3-5 seconds to load.

The line error was changing from 185 to 190. Sometimes the error changed from sef.router.php to /libraries/joomla/registry or something like that...
Last Edit: 13 years, 8 months ago by Kr3ck3n.
The topic has been locked.

Re: Version 4.3.0 - Fatal error: Maximum execution.. 13 years, 8 months ago #35638

  • Kr3ck3n
  • OFFLINE
  • Posts: 25
I have installed a backup to another directory and upgraded Joomsef to 4.3 so that you can see the error.
Here is the website running joomsef4.3.0

When I'll have some time I'll test it on localhost. Maybe the problem is the host, I don't know...
The topic has been locked.

Re: Version 4.3.0 - Fatal error: Maximum execution.. 13 years, 7 months ago #35655

  • Kr3ck3n
  • OFFLINE
  • Posts: 25
This is the error_log with joomsef4.3.0:

[09-Jan-2013 14:09:47] PHP Fatal error:  Maximum execution time of 30 seconds exceeded in /home/xxxxxxx/public_html/joomsef43/libraries/joomla/registry/registry.php on line 156
[09-Jan-2013 14:09:54] PHP Fatal error: Maximum execution time of 30 seconds exceeded in /home/xxxxxxx/public_html/joomsef43/libraries/joomla/application/menu.php on line 191
[09-Jan-2013 14:10:36] PHP Fatal error: Maximum execution time of 30 seconds exceeded in /home/xxxxxxx/public_html/joomsef43/libraries/joomla/environment/uri.php on line 412
[09-Jan-2013 14:10:54] PHP Fatal error: Maximum execution time of 30 seconds exceeded in /home/xxxxxxx/public_html/joomsef43/components/com_sef/sef.router.php on line 194
[09-Jan-2013 14:15:45] PHP Fatal error: Maximum execution time of 30 seconds exceeded in /home/xxxxxxx/public_html/joomsef43/components/com_sef/sef.router.php on line 189
[09-Jan-2013 20:59:25] PHP Fatal error: Maximum execution time of 30 seconds exceeded in /home/xxxxxxx/public_html/joomsef43/components/com_sef/sef.router.php on line 188
Last Edit: 13 years, 7 months ago by Kr3ck3n.
The topic has been locked.
User Login Empty