Menu Content

Support

> Forums, FAQs & Paid Support
Welcome, Guest
Username Password: Remember me

Docman View Button Bug When JoomSEF enabled
(1 viewing) (1) Guest
Support forum for users using free edition of JoomSEF 3 (Joomla 1.5 compatible). These forums are mainly for mutual help between users.

Please note that due to our capacity limitations, we do not monitor these forums regularly.
  • Page:
  • 1

TOPIC: Docman View Button Bug When JoomSEF enabled

Docman View Button Bug When JoomSEF enabled 9 years, 9 months ago #12597

I have two Joomla 1.5 sites that have both DOCMAN 1.4 installed and Artio JoomSEF and both are experiencing the same problem with the Docman's View button feature.

When JoomSEF is enabled the View Button produces an invalid link because it puts the backslash in the wrong place when creating the URL - "www.mysite.orgindex.php/?option=com_docman..." Note the slash is after index.php instead of before it.

When JoomSEF is totally disabled for the site the VIEW Button works and produces links like -"www.mysite.org/index.php?option=com_docman..."

When Joomla's default SEF is active and JoomSEF is inactive the View works and produces a link like: "www.mysite.org/downloads/doc_view/..."

I have tried enabling JoomSEF and setting the DocMan extension to using the "Default Joomla! router" and then to "Not using SEF " but both still produce the bad link. The Docman View button problem only goes away when I completely disable JoomSEF for the entire site.

The DOWNLOAD and DETAILS buttons both work fine. The problem is only with the VIEW button.

Because JoomSEF doesn't do this anywhere else, including the Download and Details buttons, I suspect that something is different about the code for View button that trips up JoomSEF.

What could be happening here? How can I fix this. I will try to post this on the DocMan site also.
Last Edit: 9 years, 9 months ago by soundroom. Reason: left out important phrase

Re:Docman View Button Bug When JoomSEF enabled 9 years, 8 months ago #13053

  • jc513
Any resolution to this yet? I too run DOCMAN 1.4 and am running into the same
URL rewrite with the slash in the wrong place when hitting the VIEW button.

Re:Docman View Button Bug When JoomSEF enabled 9 years, 8 months ago #13075

  • dajo
  • OFFLINE
  • Posts: 5070
Hello,

This seems like a problem with DOCman not showing the non-SEF links correctly. You can try going to JoomSEF's configuration and on the Advanced tab set "SEF URLs using component template" option to "Yes".
If that doesn't help, you should try contacting DOCman support.

Best regards,
ARTIO Support Team
ARTIO Support Team

Re:Docman View Button Bug When JoomSEF enabled 9 years, 8 months ago #13085

  • jc513
Seems to have worked. Thanks! Now to see if setting it "broke" any other part of the website.......

Re:Docman View Button Bug When JoomSEF enabled 9 years, 8 months ago #13318

Worked for me too!
  • Page:
  • 1
User Login Empty