the error is due to your smf and joomla being on seperate databases. you cna follow the bridge directions, or import your forum into your joomla database.
Now, for my issue, I get a 404 error when resolving the login, sef component only gives an option to turn off the com_smf sefurls,, which should be enough, but i still get the error.,