Menu Content

Support

> Forums, FAQs & Paid Support
Welcome, Guest
Username Password: Remember me

Agora 3 Extension
(1 viewing) (1) Guest
Support forum for customers who have purchased paid JoomSEF extension. Archive only, no new post can be added.

NOTE: This category has been locked. If you have purchased paid version, please, use our Support Ticket system instead. If you are using free edition, please see the Community Support section.
  • Page:
  • 1
  • 2

TOPIC: Agora 3 Extension

Re:Agora 3 Extension 15 years ago #7246

  • thirt
  • OFFLINE
  • Posts: 11
Thanks Jan, that seems to have fixed it.

However, the v2.0.1 has not fixed the ID issue when responding to an existing topic.

When I reply or quote a topic, I receive a http 500 error due to a missing ID. Please advise.

Thanks!
Tom
The topic has been locked.

Re:Agora 3 Extension 15 years ago #7251

  • denis
Hi thirt,

This is an known bug of Agora:
joomlame.com/index.php?option=com_agora&...sk=topic&id=4549

Best Regards
The topic has been locked.

Re:Agora 3 Extension 15 years ago #7252

  • thirt
  • OFFLINE
  • Posts: 11
Denis - I'll chime in on the joomlame.com thread you posted below, howerver I can assure you this only appears to be a problem with JoomSEF enabled. I'm hoping someone at ARTIO can dig in a bit further for me while I try and pursue the topic with Joomlame also.

Thanks,
Tom
The topic has been locked.

Re:Agora 3 Extension 15 years ago #7257

  • thirt
  • OFFLINE
  • Posts: 11
Denis - Feel free to comment on the thread at Joomlame, however the developer claims this to be an issue with the JoomSEF Agora plugin.

Actually it is not Artio causing the issue, it is the plugin Agora 3 v2.0.1 SEF Extension causing this


Any suggestions would be very much appreciated.

Thanks!
Tom
The topic has been locked.

Re:Agora 3 Extension 15 years ago #7260

  • denis
Read carefully what I said in the first message quoted by Marcus.

So yes the issue is coused by my plugin but why? Because of Agora Forum doesnt include the topic ID in Real URL. For one who has no experince on SEF (like Hazzaa) this is not coused by JoomSEF but in fact it is. JoomSEF requests an ID from Real URL(of Agora) so it will send it to the SQL query of the plugin then will fetch the title of the topic. But in this case the Agora topic URL has a NULL ID:

com_agora&id=&task=topic

So JoomSEF sends a NULL value(because Agora gives a null value) to the plugin SQL query then the 500 error page appears.

I can delete the null id value form the Real URL but then you'll have duplicated, triplicated SEF URLs.

In short, this is totally an Agora bug. That is all.
Last Edit: 15 years ago by .
The topic has been locked.

Re:Agora 3 Extension 15 years ago #7262

  • thirt
  • OFFLINE
  • Posts: 11
Denis - Understood. Would you be able to weigh in on the thread at Joomlame? I think you know your product much better than I do and would probably be able to more quickly resolve this issue if you pointed out the bug to Hazzaa.

Perhaps then Hazzaa would be able to offer a fix for this issue in an upcoming release?

But as it stands, until this issue gets resolved (with either Joomlame or ARTIO - or combination there of) this plugin is no good and should probably be taken down from the store since it can not be used.

Humbly,
Tom
The topic has been locked.
  • Page:
  • 1
  • 2
User Login Empty